1and1 & fastcgi

Discussion dans 'Administration d'un site Web' créé par jpl1er, 15 Novembre 2010.

  1. jpl1er
    jpl1er Nouveau WRInaute
    Inscrit:
    8 Mai 2010
    Messages:
    19
    J'aime reçus:
    0
    Bonjour,

    j'ai un serveur dédié clé en main chez 1&1.

    Dans l'espace client / performance du serveur / ... j'ai activé le fastcgi

    J'ai essayé les 2 lignes trouvé ici "https://www.webrankinfo.com/forum/t/fastcgi-sur-un-mutualise-chez-1-1-comment-sy-prendre.130886/"

    J'ai lu et essayé tout ce que j'ai pu trouvé (et comprendre), j'ai téléphoné à la Hotline de 1&1 pour essayer de trouver de l'aide (sans succès pour l'instant).

    J'ai bien des dossiers comme: /etc/apache/conf.d > fastcgi.conf

    Mais rien à faire, mon phpinfo.php me donne toujours:

    Server API: CGI

    Qu'est-ce que je loupe?
    Est-ce que quelqu'un parmi vous est déjà passé par là ?

    Merci
     
  2. jpl1er
    jpl1er Nouveau WRInaute
    Inscrit:
    8 Mai 2010
    Messages:
    19
    J'aime reçus:
    0
    Il semble que personne d'autre n'a ( ou a eu ) ce problème.

    Bon voici une autre information venant du site sos-dedie.
    Mais je n'ai aucune idée comment entrer ces commandes sur un dédié clé en main. Est-ce que quelqu'un a une idée ?

    Ou plus simplement, est-ce que quelqu'un parmi vous est chez 1and1 avec un serveur dédié clé en main et le fastcgi activé (et montré activ avec phpinfo.php ?

    MERCI !
     
  3. techron
    techron WRInaute occasionnel
    Inscrit:
    13 Juin 2005
    Messages:
    478
    J'aime reçus:
    0
    Suivi de ça

    Vous êtes sous Plesk ? Vous dites avoir tout fait. Avez-vous relancer votre serveur ? Relancer la reconfiguration de Plesk ? Cherchez dans le forum avec mot-clé Plesk comment reconfigurer Plesk en ligne de commande.

    cPanel aurait été un meilleur choix que Plesk en admin de serveur puisque le fastCGI comme le suPHP et tout le tralala s'active et s'installe tout simplement depuis l'interface. Donc mauvais choix de panel pour vos connaissances, mauvais choix d'hébergeur pour le support en dédié puisque 1and1 ne vous répond pas après 48 heures...
     
  4. jpl1er
    jpl1er Nouveau WRInaute
    Inscrit:
    8 Mai 2010
    Messages:
    19
    J'aime reçus:
    0

    MERCI beaucoup pour votre réponse.

    Malheureusement les dédiés ne sont ni en Plesk ni en cpanel. Je ne peux même pas relancer le serveur directement. (mais j'ai téléphoné à 1and1 pour relancer le serveur, et celui ci est aussi relancer automatiquement dans l'heure qui suit les modifications apportées).

    Le seul contrôle que j'ai c'est ssh ( Limité car pas en root) et Phpmyadmin.

    D'après le topic
    Il me suffirait d'activer fastcgi et d'ajouter a .htaccess:
    AddHandler fastcgi-script .fcgi .cgi
    Options +FollowSymLinks +ExecCGI

    Malheureusement sans succès chez moi.

    En passant en PHP6 je suis bien en fastcgi, mais mon site ne fonctionne pas en php6 !

    Comme j'étais en mutualisé, sans problème, depuis des années chez 1and1, il m'était plus simple de passer en serveur dédié clé en main (c'est aussi la seule possibilité offerte).
    Pour l'instant mon site semble tenir le coup car je viens de le lancer et il n'est pas saturé. J'ai juste peur qu'à partir d'un certain nombre de visiteur simultané, il n'arrive plus à suivre.
     
  5. techron
    techron WRInaute occasionnel
    Inscrit:
    13 Juin 2005
    Messages:
    478
    J'aime reçus:
    0
    Vous avez le même problème que dans l'autre discussion: https://www.webrankinfo.com/forum/fastcgi-sur-mutualise-chez-comment-prendr ... l#p1242316. Le client sélectionne fastCGI dans le menu http://faq.oneandone.com/dedicated_servers/managed_server/7.html mais cela ne fonctionne qu'en PHP6: http://www.1and1php.com/phpinfo.php6.

    Désolé, je ne peux pas vous aider davantage avec l'interface ''maison de 1and1''. Je ne la connais pas. Peut-être qu'un membre client 1and1 va vous aider en attendant que le support vous dépanne.

    @+
     
  6. jpl1er
    jpl1er Nouveau WRInaute
    Inscrit:
    8 Mai 2010
    Messages:
    19
    J'aime reçus:
    0
    Voici la réponse de 1and1:

    nous vous informons que FastCGI n'est pas disponible pour PHP sur les serveurs dédié clé en main.
    En effet, FastCGI n'est applicable que pour les CGI et donc il n'est pas visible sur votre php.info.


    Je dois avouer que j'ai du mal à comprendre. Pourquoi si je change en PHP 6 je peux l'utiliser pour PHP, mais pas en PHP 5.

    Aussi, qu'en est-il de "Module PHP: activé".

    Selon la F.A.Q:
    PHP module :
    Vous pouvez définir si les fichiers PHP doivent êtres traités par Apache en tant que module ou au travers de l’interface CGI d’Apache.

    Là aussi, les changements effectué dans le panneau "performances du serveurs" n'ont aucune incidence sur mon phpinfo.php

    Pour l'instant celui ci reste sur "serveur api=CGI". alors qu'il devrait être "Serveur api=Apache".

    "Serveur api=CGI" est la plus mauvaise configuration par rapport à mon site en CMS, et c'est la principale raison qui m'est motivé à changer d'un Pack Premium à un serveur dédié.
     
Chargement...
Similar Threads - 1and1 fastcgi Forum Date
1and1 et temps de chargement Administration d'un site Web 7 Septembre 2017
Nom de domaine 1and1 pour Blogger qui ne fonctionne pas Gmail, Google Talk, Blogger et Orkut 6 Juin 2017
Nom de domaine chez Infomaniak vers site 1and1 Noms de domaine et référencement 28 Novembre 2015
1and1.fr et adresses ip vraiment françaises ? Noms de domaine et référencement 19 Avril 2015
Attaque DDOS en cours chez 1and1 Administration d'un site Web 9 Décembre 2014
SERVEUR 1and1 Administration d'un site Web 31 Octobre 2014
Forcer les www | Linux - 1and1 URL Rewriting et .htaccess 15 Août 2014
Transfert nom de domaine 1and1 inclus vers Kimsufi Administration d'un site Web 29 Avril 2014
Probleme de performance 1and1 Administration d'un site Web 29 Avril 2014
Récupérer un ndd qui arrive à expiration chez 1and1 Noms de domaine et référencement 13 Mars 2014
Serveur Lcore clé en main 1and1 down Problèmes de référencement spécifiques à vos sites 15 Juillet 2013
.htaccess / url rewrite > Erreur 404.14 sur 1and1 URL Rewriting et .htaccess 19 Mai 2013
Problème 1and1 pour mapping Google Sites Administration d'un site Web 16 Mai 2013
Hebergement 1and1 - serveur dédié clé en main passage php 5.2 à php 5.4 Administration d'un site Web 3 Mai 2013
Probleme avec les noms de domaine sur 1and1 Administration d'un site Web 28 Septembre 2012
Probleme liaison table SQL et page PHP (1AND1) Développement d'un site Web ou d'une appli mobile 27 Août 2012
1and1 - Suppression de nom de domaine sans prévenir Le café de WebRankInfo 29 Juillet 2012
Rendre l'URL visible sur serveur dédié 1and1 Développement d'un site Web ou d'une appli mobile 27 Juillet 2012
Transfert de 1and1 Essential vers 1and1 classique (Wp et Prestashop) Administration d'un site Web 16 Avril 2012
[Microdata] : 1and1 OK <> OVH KO : Développement d'un site Web ou d'une appli mobile 10 Mars 2012