Activer URL Rewriting sous debian 6

neo765

WRInaute discret
Bonjour,

Je viens d'installer un serveur web sous debian 6 et je souhaiterai activer l'URL rewriting.

Cependant la structure semble différente car mon httpd.conf est vide et lorsque je souhaite y ajouter :

LoadModule rewrite_module libexec/mod_rewrite.so
AddModule mod_rewrite.c

je ne peux plus redémarrer apache.

Comment active t'on le module ?

Merci
 

neo765

WRInaute discret
Salut,

root@serveur-test:~# a2enmod rewrite
Enabling module rewrite.
Run '/etc/init.d/apache2 restart' to activate new configuration!
root@serveur-test:~# /etc/init.d/apache2 reload
Reloading web server config: apache2.

Lorsque j'affiche mon site :

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Le fichier log :

[Sun May 01 21:17:55 2011] [alert] [client 192.168.1.11] /home/user/public_html/.htaccess: Options not allowed here, referer: http://192.168.1.17/~user/create.php

Merci
 

Blount

WRInaute impliqué
La bonne nouvelle est que le module de redirection est activé.

Maintenant, il y a un souci dans ton htaccess ou un problème de permission.
Montre nous le contenu de ce ficher.
 

neo765

WRInaute discret
Blount a dit:
La bonne nouvelle est que le module de redirection est activé.

Maintenant, il y a un souci dans ton htaccess ou un problème de permission.
Montre nous le contenu de ce ficher.

Code:
# Le serveur doit suivre les liens symboliques :
Options +FollowSymlinks
# Activation du module de réécriture d'URL :
RewriteEngine on

RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-f

RewriteRule ^(.*)$ page.php?p=$1 [QSA,L]
 

neo765

WRInaute discret
seebz a dit:
Pour autoriser l'utilisation de "Options" dans le .htaccess, faut jouer avec la directive "AllowOverride" dans le vhost ;)

(Remplacer "AllowOverride None" par "AllowOverride Options" dans ton cas)
http://httpd.apache.org/docs/1.3/mod/core.html#allowoverride

<VirtualHost *:80>
ServerAdmin postmaster@user.com
ServerName http://www.user.com
ServerAlias user.com
DocumentRoot /home/user/public_html/
<Directory /home/user/public_html/>
Options -Indexes FollowSymLinks MultiViews
AllowOverride All
</Directory>
ErrorLog /home/user/logs/error.log
LogLevel warn
CustomLog /home/user/logs/access.log combined
ServerSignature Off
</VirtualHost>

J'ai donc remplacé AllowOverride All par AllowOverride Options mais le résultat est identique.

Merci
 

cmd-R

Nouveau WRInaute
Gros déterrage, mais j'ai personnellement suivi ce tuto sans pour autant réussir à activer la réécriture d'url.

Trois serveurs, trois méthodes différente, jamais réussi...
 

Discussions similaires

Haut