Envoi d'emails avec Debian Lenny!!!

cccm62

WRInaute discret
Salut,

Un prestataire a installé un PC sous Debian Lenny pour l'hébergement d'un site en local, mais impossible d'envoyer un email via PHP.
J'ai un accès SSH (pas ROOT mais apparemment j'ai certains droits) sans trop savoir quoi / ou modifier ?!

Déjà une question: si j'en crois la DOC, je suis censé pouvoir exécuter l'une de ces commandes:
- dpkg-reconfigure exim4-config: résultat: command not found!
- reportbug --configure. résultat: command not found!

C'est quoi ce biiiiins :)

Bon ok c'est peut-être moi qui n'ai rien compris, mais entre les qmail, ezmlm et djbdns (hein???), sendmail, postfix et j'en passe... le ini_set(SMTP) qui ne fonctionne que sous windows... désolé mais j'suis perdu!

En gros voilà ce que j'ai compris: par défaut on utilise exim4 (au lieu de qmail) et sous Linux pas besoin de SMTP (du php.ini). Juste cette config (qui semble bonne?):
Code:
sendmail_from        no value       no value 
sendmail_path        /usr/sbin/sendmail -t -i     /usr/sbin/sendmail -t -i
et sous SSH j'ai bien:

Code:
/usr/sbin/sendmail -> exim4
Merci d'avance à ceux qui voudront bien m'aiguiller
Cédric
 

cccm62

WRInaute discret
Code:
#:~$ /etc/init.d/exim4 start
Starting MTA:/sbin/start-stop-daemon: open pidfile /var/run/exim4/exim.pid: Permission denied (Permission denied)
:lol: Heureusement qu'on n'en a pas besoin de suite :roll:

Merci de l'info! Je vais déjà voir pour régler ça (ou pour qu'ils règlent tout eux même!).
Sinon dans l'optique où j'aurais pu... tu as d'autres infos sur le paramétrage? Ou c'est peut-être juste parce qu'exim4 n'est pas démarré?

Merci, Cédric
 

cccm62

WRInaute discret
on peut toujours espérer a dit:
~$ aptitude install sudo
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Lecture de l'information d'état étendu
Initialisation de l'état des paquets... Fait
Lecture des descriptions de tâches... Fait
E: Impossible d'ouvrir le fichier verrou /var/lib/dpkg/lock - open (13 Permission non accordée)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?

J'aime bien le are you root? à la fin lol :lol:
Ou's qu'on met "y" ?
 

cccm62

WRInaute discret
Au passage, nottons la gestion de l'encodage des caractères (j'ai pour ma part un peu de mal avec certaines notions / compatibilités au niveau encodage... mais je vois que je ne suis pas le seul apparemment)
 

julienr

WRInaute impliqué
si tu as accès physiquement à la machine, tu peux la redémarrer en mode single et faire en sorte que exim4 démarre dans ton runlevel
 

cccm62

WRInaute discret
Malheureusement non... je n'ai qu'un accès à distance + un accès VPN et TSE sur un SBS2003.
Mais peut-être que je serai amené à y passer à l'occasion. Bref je ne connais ni le "mode single" (ça n'a pas l'air très complexe et si j'ai bien compris, ça me permettrait de me logguer en root sans mot de passe!!? C'est étonnant, quand même!) ni les "runlevel"... je me renseignerai mais ça ne risque pas de créer de pb de modifier le niveau d'exécution d'une application?
 

Discussions similaires

Haut