Goûte pas à la casserole, Google...

Discussion dans 'Crawl et indexation Google, sitemaps' créé par HawkEye, 11 Octobre 2009.

  1. HawkEye
    HawkEye WRInaute accro
    Inscrit:
    23 Février 2004
    Messages:
    13 932
    J'aime reçus:
    4
    Je vous fais part d'une petite expérience désagréable à laquelle je suis confronté...

    Dans le cadre de la refonte totale d'un site web (incluant nouveau design, nouvelle structure, nouvelles URLs), j'ai protégé les nouvelles pages pendant toute la durée du développement, en les affublant d'un robots="none".

    Ces pages n'étaient liées de nulle part, mais comme chacun sait, GoogleBot se contente d'un appel de la Toolbar pour venir goûter au contenu.

    Oui mais voilà... ce faisant cet imbécile à chopé le robots="none", et semble en avoir conclu que ces pages ne devaient pas être indexées...
    Lorsque la migration vers la nouvelle structure a eu lieu, que nous avons ôté le robots="none", et que nous avons mis en place des redirections 301 depuis toutes les anciennes URLs vers les nouvelles, nous nous retrouvons avec un site partiellement désindexé:

    - la home a été virée de l'index
    - les anciennes URLs sont toujours en place, et aucune nouvelle n'est indexée

    J'ai soumis un sitemap XML, et fait une demande de réinclusion... mais je me demande si quelqu'un a déjà vécu ça... et également, ce que vous en pensez ;)
     
  2. jeanluc
    jeanluc WRInaute accro
    Inscrit:
    3 Mai 2004
    Messages:
    2 882
    J'aime reçus:
    0
    L'"imbécile" de Googlebot a simplement suivi la directive que tu lui as donnée. :wink:

    Un peu de patience devrait suffire pour que tout rentre dans l'ordre.

    Jean-Luc
     
  3. skyll
    skyll WRInaute passionné
    Inscrit:
    14 Octobre 2005
    Messages:
    1 088
    J'aime reçus:
    0
    pas mieux que Jean-Luc...
    j'ai eu un soucis du même ordre, et ca à bien mis 3/4 semaines avant de commencer à ré-indexer...
    et la ré-indexation me parraissait "+ molle" (moins de page prise en compte et plus lentement...)
    c'est rentré dans l'ordre sur 2 mois...

    ca fais combien de temps que c'est comme ca ?
     
  4. Mountain Magazin
    Mountain Magazin WRInaute occasionnel
    Inscrit:
    1 Octobre 2004
    Messages:
    496
    J'aime reçus:
    0
    Quand je fait ça, je fait un filtrage sur IP via .htaccess.

    J'autorise la mienne et celle des partenaires éventuels qui doivent accéder à la phase de développement avant la mise en prod, et aucun souci. Par exemple j'utilise un domaine en .net au lieu du .fr, et les IP non autorisées sont redirigées 301 provisoirement sur le 301.

    Comme ça, jamais de problème. Je sais que ça ne répond pas à ta question de savoir si c'est arrivé à d'autres, mais ça peut te donner des idées pour le prochain coup.
     
  5. didier26
    didier26 WRInaute discret
    Inscrit:
    1 Octobre 2009
    Messages:
    59
    J'aime reçus:
    0
    moi je fais avec un htaccess tu es sûr que y a rien qui passe !!!
     
  6. Leonick
    Leonick WRInaute accro
    Inscrit:
    8 Août 2004
    Messages:
    19 414
    J'aime reçus:
    0
    pour l'indexation, il faut juste attendre. Mais sinon, pour un site de test online, le mieux est de faire un sous-domaine dédié, qui sera complètement interdit aux moteurs
     
  7. Mountain Magazin
    Mountain Magazin WRInaute occasionnel
    Inscrit:
    1 Octobre 2004
    Messages:
    496
    J'aime reçus:
    0
    Oui, je suis sur, y a que mon IP qui est autorisée.
     
  8. aladdin
    aladdin WRInaute passionné
    Inscrit:
    29 Avril 2005
    Messages:
    1 246
    J'aime reçus:
    0
    @HawkEye : s'agit-t-il simplement d'une refonte ? ou refont+migration du serveur ?

    car dans le deuxième cas, il est tout à fait normal que googlebot mette du temps : 2 à 4 semaines , mais ça va repartir...

    sinon je trouve quand même bizzard que googlebot utilise la googletoolbar pour découvrir du contenu !!
     
  9. L.Jee
    L.Jee WRInaute accro
    Inscrit:
    11 Décembre 2007
    Messages:
    5 432
    J'aime reçus:
    4
    J'ai vu passer le cas la semaine dernière, c'est abusé, pauvre de lui :)
     
  10. Ohax
    Ohax WRInaute accro
    Inscrit:
    5 Juillet 2004
    Messages:
    4 920
    J'aime reçus:
    0
    +1

    Je travaille aussi ainsi, aucun problème :)
     
Chargement...
Similar Threads - Goûte casserole Google Forum Date
Dégouté d'online.net : problèmes sur hebergement "pro" Administration d'un site Web 11 Août 2014
  1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies.
    Rejeter la notice