Probleme de PHP sur serveur dédié

Discussion dans 'Administration d'un site Web' créé par Jerome38190, 24 Février 2009.

  1. Jerome38190
    Jerome38190 Nouveau WRInaute
    Inscrit:
    14 Mai 2007
    Messages:
    10
    J'aime reçus:
    0
    Bonjour,

    J'ai voulu installer ioncube (une extension PHP) sur mon serveur dédié parce qu'il m'était nécessaire a une application.

    J'ai donc modifié le php.ini pour ajouter une ligne (zend_extension = /usr/local/ioncube/ioncube_loader_lin_5.2.so) tout en haut du fichier.
    Comme ca n'a pas marché j'ai fait un php -v pour voir si y'avais pas d'erreur et il y'en a :D

    php: /lib/libpam.so.0: no version information available (required by php)
    PHP Warning: mime_magic: type regex BEGIN[[:space:]]*[{] application/x-awk invalid in Unknown on line 0
    PHP Warning: mime_magic: type search/400 \\input text/x-tex invalid in Unknown on line 0
    PHP Warning: mime_magic: type search/400 \\section text/x-tex invalid in Unknown on line 0
    PHP Warning: mime_magic: type search/400 \\setlength text/x-tex invalid in Unknown on line 0
    PHP Warning: mime_magic: type search/400 \\documentstyle text/x-tex invalid in Unknown on line 0
    PHP Warning: mime_magic: type search/400 \\chapter text/x-tex invalid in Unknown on line 0
    PHP Warning: mime_magic: type search/400 \\documentclass text/x-tex invalid in Unknown on line 0
    PHP 4.4.8_pre20070816-pl1-gentoo (cgi) (built: Apr 1 2008 11:46:26)
    Copyright (c) 1997-2007 The PHP Group
    Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies


    Tout ca, comme je suis débutant en administration de serveur dédié je sais pas trop a quoi c'est du...
    Je suis preneur de toute idée

    Merci


    edit : pour info je suis sous gentoo, j'ai essayer de reinstaller pam mais rien changé (je sais même pas ce que c'est pam ?)
     
  2. k2pi
    k2pi WRInaute occasionnel
    Inscrit:
    4 Février 2007
    Messages:
    274
    J'aime reçus:
    0
    Tu as fait quoi pour installer ioncube ?
     
  3. Jerome38190
    Jerome38190 Nouveau WRInaute
    Inscrit:
    14 Mai 2007
    Messages:
    10
    J'aime reçus:
    0
    Salut, merci pour ta réponse ...

    Pas grand chose en fait, j'ai juste copier le fichier ioncube_loader_lin_5.2.so dans /usb/local/ioncube
    et j'ai mis cette ligne dans php.ini :
    zend_extension = /usr/local/ioncube/ioncube_loader_lin_5.2.so

    C'est tout ... alors peut-être le problème est ultérieur à ça ou alors j'ai mis un caractères quelque part par inattention mais pour vérifier ça ...
    J'ai d'ailleurs remarqué hier en faisant un emerge --synch que le emerge me disait que mon profil est obsolète... Je sais pas trop ce que ça veut dire j'ai pas encore trop eut le temps de chercher.

    Pas facile de débuter sur l'administration d'un dédié, je sais bien que c'est un métier mais comme c'est un serveur que j'ai à titre particulier j'ai pas vraiment les moyens de mettre des sous dans de l'infogérance

    merci
     
  4. Jerome38190
    Jerome38190 Nouveau WRInaute
    Inscrit:
    14 Mai 2007
    Messages:
    10
    J'aime reçus:
    0
    De pire en pire j'ai meme plus l'accés SSH et dans le webdmin d'ovh j'ai ca :

    Code:
    Impossible d'obtenir un numéro de version du programme serveur SSH /usr/sbin/sshd. Peut-être votre configuration du module est-elle incorrecte. La sortie de la commande /usr/sbin/sshd -h était : 
    :cry: Et j'ai plus d'accés FTP ... Je me disais je vais sauvegarder et relancer l'install de l'OS a zéro, tout est mort quoi je vais essayer de contacter ovh
     
  5. julienr
    julienr WRInaute impliqué
    Inscrit:
    5 Août 2003
    Messages:
    941
    J'aime reçus:
    0
    mauvaise réponse .. :)
     
  6. DaviXX
    DaviXX Nouveau WRInaute
    Inscrit:
    14 Août 2005
    Messages:
    23
    J'aime reçus:
    0
    Bonjour,

    Je pense que ton disque est bientôt HS au vu de ce que tu décris.
    Tu as tenté un reboot en rescue avec un test de HDD ?

    --
    David CHANIAL
     
  7. Jerome38190
    Jerome38190 Nouveau WRInaute
    Inscrit:
    14 Mai 2007
    Messages:
    10
    J'aime reçus:
    0
    Bonjour,

    Oui j'ai reboot en rescue et vérifier tous le systéme ca venait pas de la... J'ai finalement reinstaller tout l'OS et c'est bon ... super pratique ca me fait peur que ca le refasse (c'est un kimsufi, j'avais pas les moyens pour mieux, c'est pas cher mais si c'est toujours la merde comme ca ...)

    Effectivement julienr, la hotline m'a envoyé boulé sous pretexte que c'est un kimsufi ... "On fait du support que pour les pros mais vous avez accés aux guides" super merci

    Merci à tout le monde dans tous les cas
     
Chargement...
Similar Threads - Probleme PHP serveur Forum Date
probleme creation fichier php sur serveur Développement d'un site Web ou d'une appli mobile 15 Juillet 2010
URL canonique et problème entre / et /index.php Débuter en référencement 20 Janvier 2021
Probleme forum phpbb seo Développement d'un site Web ou d'une appli mobile 30 Septembre 2018
Problème de duplicate content avec des URLs contenants /index.php/ URL Rewriting et .htaccess 14 Mai 2018
Problème hiérarchie de classes php. Développement d'un site Web ou d'une appli mobile 9 Janvier 2018
Problème images en https (forum phpbb) [résolu] Développement d'un site Web ou d'une appli mobile 18 Novembre 2017
PHP -Problème retraitement données Mysql avant envoit dans un tableau array Développement d'un site Web ou d'une appli mobile 28 Décembre 2016
Problème avec l'envoi d'un mail sans contenu php Développement d'un site Web ou d'une appli mobile 7 Septembre 2016
Un problème avec php7 Administration d'un site Web 1 Août 2016
Problème erreur redirection cakephp URL Rewriting et .htaccess 4 Avril 2016