Pub Adsense n'apparait pas sur certains mobiles

Bertrand57

WRInaute discret
Bonjour,

J'ai remarqué que mes pubs Adsense ne s'affichent pas sur certains mobiles.
J'ai pu tester sur un Galaxy A8 et un S8 : aucune des pubs Adsense du site ne s'affiche, quel que soit le bloc d'annonce.
Par contre, sur un iPhone 5S, cela fonctionne.

Ce problème d'affichage doit être répandu sur de nombreux modèles de mobiles, car j'ai 2 à 3 fois moins d'affichages d'annonces que de pages vues sur mobiles.
L'écart est bien moindre pour les pages vues et les affichages sur ordinateur (écart surement du aux bloqueurs de pub)..

Voici l'URL du site www.amenagementdujardin.net

Pouvez-vous m'aider ?
Je n'arrive à comprendre d'où vient le souci.

Merci
 

rick38

WRInaute passionné
Il y a un problème effectivement, mais ça n'est pas lié aux mobiles, sous Chrome, en réduisant la largeur, il y a le même souci, le chargement de la pub est annulé.

Et je vois qu'il est utilisé un plugin WordPress : "Quick Adsense Wordpress Plugin", sans doute qu'il foire (?)
 

Bertrand57

WRInaute discret
Le plugin "Quick Adsense Wordpress Plugin" gère uniquement les bannières horizontales. Le souci concerne aussi la pub dans la colonne de droite (qui est déplacée en bas de page en vue mobile) et le code de cette pub est mis directement dans un widget Wordpress, ça ne passe pas par "Quick Adsense Wordpress Plugin".

En plus, j'ai le même souci sur un autre de mes sites où les codes des pubs sont intégrés directement dans les fichiers du thème.

Le seul point commun de ces sites, ce sont les thèmes qui ont été créés avec le même logiciel (Artisteer).
Je pense donc que le problème se situe au niveau du thème, mais je ne trouve pas le code précis pour l'instant.
 

rollback

WRInaute occasionnel
je n'ai pas regardé le site, mais effectivement , souvent c'est du a des problèmes de CSS qui ne sont pas supporté par tous les browsers. Généralement c'est plutôt des machines apple qui ne supportent pas les marges négatives, ce type d"erreur...
 

Bertrand57

WRInaute discret
Merci. Je suis arrivé à régler le problème.
Le thème Wordpress utilisé agissait sur les iframes pour les rendent responsives, ce qui engendraient des soucis avec celles de Adsense. Je suis arrivé à exclure les iframes d'Adsense de cette fonctionnalité.
 

Discussions similaires

Haut