Safari ne peut pas établir de connexion sécurisée au serveur

saluts92

WRInaute passionné
Bonjour,

Je viens de télécharger Safari 5.1.7 (7534.57.2) sur un PC Windows 10 (et un autre essaie avec Windows 7) pour faire quelques tests de mon site et je m'aperçois que j'ai le message suivant :

"Safari ne parvient pas à ouvrir la page 'https://www.monsite.com/' car Safari ne peut pas établir de connexion sécurisé au serveur 'www.monsite.com' "
Bien entendu mon certificat est valide et ne m'a posé aucun problème depuis de nombreuses années (test avec SSl checker par exemple)

J'ai essaye d'autres nombreux site et aucun ne me retourne ce message.

j'ai vidé les caches, (etc ...) et j'ai toujours le même message.

Auriez-vous une explication s'il vous plait ?

PS: sur un MAC et IPHONE cela fonctionne mais ce n'est pas le meme version de Safari : la version de Safari étant bloqué à 5.1.7 pour Windows depuis 2019.
 

emualliug

WRInaute impliqué
Sans URL, ce sera pure conjoncture : le serveur n'accepte pas d'établir une liaison en TLS 1.0. Safari supporte TLS 1.1 depuis la version 7 uniquement.
 

saluts92

WRInaute passionné
Effectivement je viens d'avoir la meme réponse en parrallèle, merci

Le certificat de mon site est en avance sur son temps en fait


donc plus possible de faire des teste Safari depuis un poste Windows ?
 

emualliug

WRInaute impliqué
Si, mais il faut que le serveur accepte du TLS 1.0 en plus de 1.1 et surtout de 1.2 (les navigateurs ont annoncé ne plus prendre en charge TLS 1.0 et 1.1 courant 2020, et ils sont en passe d'être dépréciés). C'est ce que font les autres sites qui n'élèvent pas l'erreur que tu rencontres.

Certains considèrent qu'il faut songer à désactiver TLS 1.0 côté serveur si le site est "sensible". Toutefois, dans la très grande majorité des cas, seul l'internaute est exposé avec une connexion mal chiffrée, et c'est son problème de ne pas supporter TLS 1.2. En plus, je ne vois pas comme ça de solution élégante pour renvoyer l'internaute qui a un vieux navigateur vers une page (non sécurisée) qui lui indique que sa trop vieille version de TLS ne lui permet pas d'accéder au site.
 

Discussions similaires

Haut