Wamp : soucis d'url sans extension?

tryan

WRInaute passionné
Bonjour,

J'utilise depuis peut Wampserver (2.2) et je suis confronté à un soucis d'url...
Par exemple sous FREE, une url du type "/categorie-1/hypertext-markup-language" (sans rewriting) affiche correctement la page bien que l’extension ".php" ne soit pas précisé dans l'url. Sous Wamp, cette même page m'indique une erreur 404 car il ne reconnait pas la page sans son extension.
Comment pallier à ce problème?

Merci
 

erestrebian

WRInaute occasionnel
Je dirais en interprétant tout comme du php. Je pense qu'il faut chercher du côté de httpd.conf dans la partie apache de wamp .
Code:
<IfModule mime_module>
    #
    # TypesConfig points to the file containing the list of mappings from
    # filename extension to MIME-type.
    #
    TypesConfig conf/mime.types

    #
    # AddType allows you to add to or override the MIME configuration
    # file specified in TypesConfig for specific file types.
    #
    #AddType application/x-gzip .tgz
    #
    # AddEncoding allows you to have certain browsers uncompress
    # information on the fly. Note: Not all browsers support this.
    #
    #AddEncoding x-compress .Z
    #AddEncoding x-gzip .gz .tgz
    #
    # If the AddEncoding directives above are commented-out, then you
    # probably should define those extensions to indicate media types:
    #
    AddType application/x-compress .Z
    AddType application/x-gzip .gz .tgz
    AddType application/x-httpd-php .php
    AddType application/x-httpd-php .php3
    AddType application/x-httpd-php .php5

    #
    # AddHandler allows you to map certain file extensions to "handlers":
    # actions unrelated to filetype. These can be either built into the server
    # or added with the Action directive (see below)
    #
    # To use CGI scripts outside of ScriptAliased directories:
    # (You will also need to add "ExecCGI" to the "Options" directive.)
    #
    #AddHandler cgi-script .cgi

    # For type maps (negotiated resources):
    #AddHandler type-map var

    #
    # Filters allow you to process content before it is sent to the client.
    #
    # To parse .shtml files for server-side includes (SSI):
    # (You will also need to add "Includes" to the "Options" directive.)
    #
    #AddType text/html .shtml
    #AddOutputFilter INCLUDES .shtml
</IfModule>

J'avais besoin que mon serveur local interprète aussi les .php5 et j'ai rajouté cette ligne : AddType application/x-httpd-php .php5. Par contre, je ne sais pas comment faire quand on a pas d'extension et si cela ne risque pas de poser problème avec d'autres type de fichiers.

En espérant que cela ait pu aider.
 

tryan

WRInaute passionné
Bonjour et merci de vos réponses,

L'option MultiViews semble fonctionner sous Wamp et m'affiche maintenant la page sans son extension. Cependant il semblerait que ce soit "dangereux" car il suffirait de tomber sur une extension inconnue pour que php tente de l’interpréter...
Code:
Options +MultiViews
RewriteEngine on
ForceType application/x-httpd-php
Cette explication ma été donné sur le forum de Wamp ainsi qu'une seconde solution à laquelle je n'ai absolument rien comprit pour le moment :( .
Au cas ou cette discussion puisse servir à quelqu'un d'autre dans le même cas que moi, je donne l'url du poste en question http://www.wampserver.com/phorum/read.php?1,78543
 

Discussions similaires

Haut