xhtml strict et xiti

Discussion dans 'Administration d'un site Web' créé par ludoanimation, 26 Mars 2004.

  1. ludoanimation
    ludoanimation WRInaute impliqué
    Inscrit:
    25 Juillet 2003
    Messages:
    677
    J'aime reçus:
    0
    Salut,

    j'essaye de réécrire mon site en xhtml strict et full css et j'ai un probleme avec le code du marqueur xiti qui ne passe pas au validateur w3c.

    Quelqu'un a t'il déja été confronté a ce probleme ? comment le résoudre ?

    Ludo
     
  2. Monique
    Monique WRInaute passionné
    Inscrit:
    16 Septembre 2002
    Messages:
    1 153
    J'aime reçus:
    0
  3. ludoanimation
    ludoanimation WRInaute impliqué
    Inscrit:
    25 Juillet 2003
    Messages:
    677
    J'aime reçus:
    0
    bonjour monique,

    Bon et bien il faut attendre :cry: , ou alors peut etre une autre idée , mettre le code de xiti en CDATA :

    Code:
    <![CDATA[code javascript de xiti...]]>
    je pense que ce n'est pas interdit par xiti et ca devrait passer au W3C.

    par contre je n'ai pas encore testé donc sous reserve

    Ludo
     
  4. Monique
    Monique WRInaute passionné
    Inscrit:
    16 Septembre 2002
    Messages:
    1 153
    J'aime reçus:
    0
    Je n'ai pas testé non plus...

    Amicalement,
    Monique
     
  5. thickparasite
    thickparasite WRInaute passionné
    Inscrit:
    27 Avril 2003
    Messages:
    1 140
    J'aime reçus:
    0
    J'ai bidouillé le code de ma page HTML pour le script
    Partout où tu as " & ", il faut mettre " & " et ça marche.

    Ceci dit, j'ai pas trouvé un script qui passe le validateur ... A méditer !
     
  6. Monique
    Monique WRInaute passionné
    Inscrit:
    16 Septembre 2002
    Messages:
    1 153
    J'aime reçus:
    0
    & suivi de amp sans espace

    Rien à faire... pas moyen de le faire passer correctement, même en utilisant les balises code :?

    A ces corrections près, le code que je propose à la page 4 du lien que j'ai donné est valide.

    Amicalement,
    Monique
     
  7. thickparasite
    thickparasite WRInaute passionné
    Inscrit:
    27 Avril 2003
    Messages:
    1 140
    J'aime reçus:
    0
    Toutes mes excuses, j'ai mon copier-coller qui a fourché ...

    C'est " & " que tu mets à la place de " & "
     
  8. Monique
    Monique WRInaute passionné
    Inscrit:
    16 Septembre 2002
    Messages:
    1 153
    J'aime reçus:
    0
    :lol: :lol: :lol:

    Si tu trouves le moyen d'écrire ça correctement, thick, tu auras droit à toute mon admiration :D

    Amicalement,
    Monique
     
  9. thickparasite
    thickparasite WRInaute passionné
    Inscrit:
    27 Avril 2003
    Messages:
    1 140
    J'aime reçus:
    0
  10. thickparasite
    thickparasite WRInaute passionné
    Inscrit:
    27 Avril 2003
    Messages:
    1 140
    J'aime reçus:
    0
  11. thickparasite
    thickparasite WRInaute passionné
    Inscrit:
    27 Avril 2003
    Messages:
    1 140
    J'aime reçus:
    0
    Je sais pas ça marche pas. Tu mets ton & puis amp puis ; (tout attaché bien sûr, mais je sais pas pourquoi ça veut pas s'écire ds le post
     
  12. thickparasite
    thickparasite WRInaute passionné
    Inscrit:
    27 Avril 2003
    Messages:
    1 140
    J'aime reçus:
    0
    Désolé ....

    Avez-vous saisi cette fois ?
     
  13. Monique
    Monique WRInaute passionné
    Inscrit:
    16 Septembre 2002
    Messages:
    1 153
    J'aime reçus:
    0
    Ben il faudra que tu attendes pour bénéficier de toute mon admiration thick :lol:

    Je reconnais que tu n'es pas en cause !
    Moi aussi, j'ai essayé par tous les moyens de faire passer ce & amp sans l'espace mais phpBB ne veut pas :cry:

    Amicalement,
    Monique
     
  14. thickparasite
    thickparasite WRInaute passionné
    Inscrit:
    27 Avril 2003
    Messages:
    1 140
    J'aime reçus:
    0
    J'avais en effet optimisé en HTML 4.01 pour ce site http://www.pro34.com/ qui valide le code Xiti

    J'ai testé sur mon brouteur d'autruche -http://www.7-dragons.com qui est en XHTML 1.0 et en effet, il me sort des erreurs, mais je pense que ça peut se corriger. Je vais plancher un peu dessus, mais vous pouvez tester en prenant le résultat du valdateur du bouffeur de poulette ici
    -http://validator.w3.org/check?uri=http%3A%2F%2Fwww.7-dragons.com


    <edité : suppression des noms et URL relatives au concours de bouffeur de poupoule, utilisez la discussion dédiée>
     
  15. George Abitbol
    George Abitbol WRInaute passionné
    Inscrit:
    6 Juin 2003
    Messages:
    1 519
    J'aime reçus:
    0
    Test : &amp; ?

    Fred

    (edit : et hop 8) )
     
  16. thickparasite
    thickparasite WRInaute passionné
    Inscrit:
    27 Avril 2003
    Messages:
    1 140
    J'aime reçus:
    0
    Merci George pour avoir mis ce que mon clavier et WRI n'ont pas su s'entendre pour écrire.
    Allez, j'essaye une dernière fois

    &
     
  17. thickparasite
    thickparasite WRInaute passionné
    Inscrit:
    27 Avril 2003
    Messages:
    1 140
    J'aime reçus:
    0
    Ca veut vraiment pas ... bizarre bizarre
     
  18. George Abitbol
    George Abitbol WRInaute passionné
    Inscrit:
    6 Juin 2003
    Messages:
    1 519
    J'aime reçus:
    0
    Bon, allez, le mystère révélé ;)

    Puisque &amp; donne &, pour avoir un &amp; il suffit d'écrire &amp;amp; (et ainsi de suite : pour écrire &amp;amp; j'ai dû écrire &amp;amp;amp;...)

    Fred
     
  19. thickparasite
    thickparasite WRInaute passionné
    Inscrit:
    27 Avril 2003
    Messages:
    1 140
    J'aime reçus:
    0
  20. thickparasite
    thickparasite WRInaute passionné
    Inscrit:
    27 Avril 2003
    Messages:
    1 140
    J'aime reçus:
    0
    YES !!!!
    Merci (remarque je suis trop con !)
     
  21. Monique
    Monique WRInaute passionné
    Inscrit:
    16 Septembre 2002
    Messages:
    1 153
    J'aime reçus:
    0
    Bonjour,

    C'est donc toi qui a droit à toute mon admiration, Fred :D

    &amp;

    Il suffisait d'y penser :roll:

    Amicalement,
    Monique
     
  22. George Abitbol
    George Abitbol WRInaute passionné
    Inscrit:
    6 Juin 2003
    Messages:
    1 519
    J'aime reçus:
    0
    Bon, par contre dès qu'on cite ou qu'on édite, y'a tout à refaire, hein :D

    Fred
     
  23. thickparasite
    thickparasite WRInaute passionné
    Inscrit:
    27 Avril 2003
    Messages:
    1 140
    J'aime reçus:
    0
    Et pour la validation du script, ça marche ?
     
  24. ideezik
    ideezik WRInaute impliqué
    Inscrit:
    28 Janvier 2004
    Messages:
    792
    J'aime reçus:
    0
    Je me penche aussi sur le pb... Pour l'instant il me reste encore 5 erreurs au validateur :

    Si quelqu'un a le code tout beau tout propre en xhtml strict, j'suis preneur...

    David
     
  25. thickparasite
    thickparasite WRInaute passionné
    Inscrit:
    27 Avril 2003
    Messages:
    1 140
    J'aime reçus:
    0
    Me contacter par MP, j'ai le sésame (made in Ludoanimation)
     
  26. milkiway
    milkiway WRInaute accro
    Inscrit:
    3 Février 2004
    Messages:
    4 196
    J'aime reçus:
    0
    Je ne comprends vraiment pas ce que vous cherchez. Vous voulez faire valider par un validateur XHTML du javascript ?!
    Ce ne sont pas les même langages !
     
Chargement...
Similar Threads - xhtml strict xiti Forum Date
pb de validation Doctype XHTML strict Développement d'un site Web ou d'une appli mobile 2 Février 2010
Impossible de valider mon formulaire XHTML 1.0 Strict Développement d'un site Web ou d'une appli mobile 16 Juin 2009
XHTML 1.0 strict & CSS, style height avec la norme Développement d'un site Web ou d'une appli mobile 13 Juillet 2008
XHTML strict non reconnu sous IE (.htaccess) URL Rewriting et .htaccess 9 Juillet 2008
onFocus et XHTML Strict Développement d'un site Web ou d'une appli mobile 8 Décembre 2007
FCKeditor et validation (xhtml 1.1 ou 1.0 strict) Développement d'un site Web ou d'une appli mobile 23 Mai 2007
XHTML strict ou XHTML 1.0 Transitional ? Administration d'un site Web 10 Août 2006
target=_blank pour site valid XHTML strict Développement d'un site Web ou d'une appli mobile 29 Mars 2006
Mon site valide XHTML strict Développement d'un site Web ou d'une appli mobile 25 Mars 2006
TEXTAREA et validité XHTML strict Développement d'un site Web ou d'une appli mobile 23 Mars 2006
This Page Is Valid XHTML 1.0 Strict! - et le référencement ? Techniques avancées de référencement 23 Février 2006
[XHTML 1.0 Strict] - Formulaire valide Développement d'un site Web ou d'une appli mobile 17 Février 2006
XHTML 1.0 Strict et les tableaux Développement d'un site Web ou d'une appli mobile 5 Janvier 2006
[résolu] Besoin d'aide pour une validaton XHTML 1.0 Strict Développement d'un site Web ou d'une appli mobile 11 Septembre 2005
[marquee] Equivalent en xhtml strict Administration d'un site Web 21 Juillet 2005
Plume CMS : un CMS qui génère du XHTML 1.0 Strict Administration d'un site Web 5 Juin 2005
XHTML 1.0, HTML 4.01, Basic ou strict....??? Problèmes de référencement spécifiques à vos sites 1 Juillet 2004
Pb avec usemap en xhtml 1.1 strict Problèmes de référencement spécifiques à vos sites 18 Mai 2004
Validateur XHTML1.1 Strict... Monique, au secours !!! Administration d'un site Web 10 Mai 2004
Plusieurs balises H1 XHTML possible ? Développement d'un site Web ou d'une appli mobile 2 Janvier 2015