Migration de serveur ou pas?

richard1

Nouveau WRInaute
Bonjour,
je possède actuellement un serveur Kimsufi XL chez ovh (ubuntu, Achache, postfix, PHP5), le problème c'est que depuis quelques semaines j'ai une augmentation régulière de mes visites en gros en ce moment je tourne à 9000 VU jour.
Sur le serveur, plusieurs blogs (wordpress) sont hébergés (par moi ou des amis).
Les visiteurs viennent des quatre coins de la planete car en plusieurs langues (espagnol et Français)
Le serveur me fait deux ou trois fois par jour des plantages sévères (plus de SSH, plus de contrôle, juste réponse aux pings).
Les blogs hébergent pas mal de photos et de posts, mais je possède plusieurs caches (apache et wordpress).
Ma question serait : est ce la limitation du CPU et de la Ram ( 3000MHZ et 2Gigas de ram) qui font cela, ou simplement le manque de BP (je suis en Standard séries.) ou simplement une mauvaise config de mon serveur...

Pour pouvoir continuer à me développer et résoudre ce problème, je souhaiterais monter de gamme, que me conseillez vous, un Kimsufi 4XL ou un SuperPlan BestOF ??
Sachant que à part le prix, je ne vois pas de grande différence entre les deux...
Dernière question, serait il judicieux de laisser ma BD sur le XL et de prendre un deuxième serveur 4XL ou superplan pour apache et le courrier??
Voila, je sais que j'ai été long, mais je suis très inquiet et ne sais pas quoi faire...
Je vous remercie par avance pour vos judicieuses réponses.
Cordialement,
Richard
 

biddybulle

WRInaute passionné
ca doit être une mauvaise config du serveur. 9000 ca semble très faible pour des blogs surtout si tu as du cache.

Il y a sans doute des processus non désirés qui sature la machine et entraine le plantage.

si tu as la main par ssh, tu peux vérifier avec la commande top et voir le niveau de charge.
 

raljx

WRInaute passionné
Tu as bien des services de monitoring (cacti ou autre) ?
Ça te permettrais en un clin d'œil de voir ou cela bloque ... (montées en charge /CPU /RAM / espace disque...)

je suis de l'avis de biddybulle concernant principalement la non optmisation de la config apache mais reste a savoir aussi combien de VU on les autres sites ...

Une bonne config et tu tiens facilement sans plantage du 9000VU PAR HEURE (bon peut etre pas sur un Kimsufi :\ et ses 2Go sur le XL) mais ya encore un peu de marge :)
 

richard1

Nouveau WRInaute
Bonjour, la charge augmente ponctuellement, avec top je suis en moyenne a 20% de proc et 1400Mo de ram (normal pour linux)
Ce qui m'etonne c'est que le serveur par moment, lors de pics devient ingerable et je n'ais plus acces à SSH.
9000 vu/ jour ça me fait en gros 40.000 pages vues par 24H. donc la j'ai un gros doute...
et ce qui m'inquiéter c'est que je ne peut plus accéder à SSh pour faire de kill.
Donc je pense que ça vient de pics de clients. Qu'en pensez vous?
 

biddybulle

WRInaute passionné
Cela peut être des erreurs dans des plugins wordpress qui ont laissé trainé une faille qui ont permis à des pirates via des includes d'installer des clients, trojan, irc ... qui tournent sur ton serveur et qui t'amène de nouveaux clients :)

regarde les processus qui tourne, rien de bizarre ?

regarde tes logs SSH, pas des milliers de tentative de connection par seconde ?

Le serveur plante t-il toujours vers la même heure ?
 

dahousemix

Nouveau WRInaute
Ca me fais penser au problème de fichiers logs trop importants sur les release 1 et 2 de OVH si c'est tous les jours à la même heure (l'heure d'archivage des logs quoi).
Dans ce cas il suffit de mieux configurer les logs pour qu'ils ne prennent exactement que ce qui t'intéresse (moi j'ai viré les appels à certains fichiers et certains dossiers récurrents). Tu peux également stopper la réplication de mysql si tu n'utilise pas cette fonction (je sens que certains vont hurler de lire ça)
 

richard1

Nouveau WRInaute
Mon irc est bloqué et j'ai un firewall (Iptables)maison assez restrictif.
quand aux trojans, j'ai Rkhunter.
Les logs SSH sont ok et je ne vois rien de bizarre dans mes logs???
le pire c'est que ce n'est jamais à la même heure et il semble que le plantage vient de la me moire qui monte à 99% et le CPU aussi.
donc la je nage total :cry:
Juste sur les logs Apache pas mal de:

Mes sites sont dans /Home pas dans var!!!

ERROR: opening '/var/lib/cacti/rra/localhost_mem_buffers_3.rrd': No such file or directory
ERROR: opening '/var/lib/cacti/rra/localhost_mem_swap_4.rrd': No such file or directory
ERROR: opening '/var/lib/cacti/rra/localhost_mem_buffers_3.rrd': No such file or directory
ERROR: opening '/var/lib/cacti/rra/localhost_mem_swap_4.rrd': No such file or directory
ERROR: opening '/var/lib/cacti/rra/localhost_mem_buffers_3.rrd': No such file or directory
ERROR: opening '/var/lib/cacti/rra/localhost_mem_buffers_3.rrd': No such file or directory
ERROR: opening '/var/lib/cacti/rra/localhost_mem_swap_4.rrd': No such file or directory
ERROR: opening '/var/lib/cacti/rra/localhost_mem_buffers_3.rrd': No such file or directory
ERROR: opening '/var/lib/cacti/rra/localhost_mem_swap_4.rrd': No such file or directory

Mon Dec 08 04:40:25 2008] [error] [client 206.49.165.26] Invalid method in request \x16\x03\x01
[Mon Dec 08 04:40:55 2008] [error] [client 206.49.165.26] Invalid method in request \x16\x03\x01
[Mon Dec 08 04:41:30 2008] [error] [client 206.49.165.26] Invalid method in request \x16\x03\x01
[Mon Dec 08 04:42:40 2008] [error] [client 206.49.165.26] Invalid method in request \x16\x03\x01

et:
Mon Dec 08 05:39:21 2008] [error] [client 84.19.184.146] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.DFind:)
[Mon Dec 08 05:47:23 2008] [error] [client 84.19.184.146] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.DFind:)
[Mon Dec 08 05:53:23 2008] [error] [client 84.19.184.146] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.DFind:)
[Mon Dec 08 06:01:31 2008] [error] [client 84.19.184.146] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.DFind:)
[Mon Dec 08 07:23:19 2008] [error] [client 84.19.184.146] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.DFind:)
[Mon Dec 08 07:35:07 2008] [error] [client 84.19.184.146] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.DFind:)
[Mon Dec 08 08:38:28 2008] [error] [client 84.19.184.146] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.DFind:)
[Mon Dec 08 08:50:09 2008] [error] [client 84.19.184.146] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.DFind:)
[Mon Dec 08 09:53:16 2008] [error] [client 84.19.184.146] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.DFind:)
[Mon Dec 08 10:04:53 2008] [error] [client 84.19.184.146] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.DFind:)

Quelqu'un a une idée??
Merci d'avance
:wink:
 

Discussions similaires

Haut