Migration PHP

Discussion dans 'Développement d'un site Web ou d'une appli mobile' créé par walking7, 25 Août 2015.

  1. walking7
    walking7 WRInaute passionné
    Inscrit:
    17 Février 2009
    Messages:
    1 556
    J'aime reçus:
    7
    Bonjour,
    Recu ce message depuis un mois, j'avais mis de coté et maintenant je m'y met.
    J'ai déja mal à la tete à peine commencé.. Je pige pas, je dois faire une manip ou pas ? .. car 5.4 ca suffirait visiblement. Et comme c'est fait en auto. Je suis obligé de passer en 5.6 ? D'entrée l'explication est contradictoire !!

     
  2. Blount
    Blount WRInaute impliqué
    Inscrit:
    18 Novembre 2010
    Messages:
    707
    J'aime reçus:
    0
    Bah tu dois rendre compatible avec PHP 5.4 au minimum (si t'as rien touché au niveau config OVH, ce sera cette version par défaut).

    Mais tant qu'à faire, autant y aller à fond et rendre compatible PHP 5.6, voir PHP 7 (oui 7, pas 5.7 ^^). De mes tests, PHP7 déboîte pas mal au niveau perf, ce sera donc une bonne chose que tu sois prêt au plut tôt pour en bénéficier quand OVH la mettra à dispo.
     
  3. walking7
    walking7 WRInaute passionné
    Inscrit:
    17 Février 2009
    Messages:
    1 556
    J'aime reçus:
    7
    J'ai controlé la version est c'est effectivement passé automatiquement en 5.4.38 ..
    .. je n'ai donc rien à faire (pour l'instant) ?!?

    Ca veut dire quoi rendre compatible concrètement ? Regarder si l'affichage et la navig n'est pas perturbé depuis qu'ils m'ont passé en 5.4 c'est ça ?

    En résumé, je dois réaliser des opérations si je reste en 5.4 ou pas ?

    merci, je nage (une fois de plus lol)
     
  4. walking7
    walking7 WRInaute passionné
    Inscrit:
    17 Février 2009
    Messages:
    1 556
    J'aime reçus:
    7
    Bon en fait j'ai édité le fichier .ovhconfig pour passer en 5.6

    C'est bête comme bonjour, il suffit de remplacer 5.4 par 5.6
    Et c'est tout ? lol

    J'ai contrôlé, mes sites sont bien passés en 5.6.6 .. et ca semble fonctionner.
    Mais je dois vérifier quoi exactement pour voir si tout fonctionne nickel ?
     
  5. indigene
    indigene WRInaute accro
    Inscrit:
    7 Septembre 2003
    Messages:
    3 747
    J'aime reçus:
    82
    Ben tout.
    Moi par exemple je n'avais plus aucune balise TITLE qu'i s'affichait et je ne pouvais plus accéder à ma console d'administration sur le site que j'ai basculé.

    Ca se fait à quelle date en automatique ?
     
  6. walking7
    walking7 WRInaute passionné
    Inscrit:
    17 Février 2009
    Messages:
    1 556
    J'aime reçus:
    7
    Tout, tu veux dire qu'on se rend compte de problème simplement en naviguant sur le site ?


    24 sept. => 5.4 en auto
     
  7. Marie-Aude
    Marie-Aude WRInaute accro
    Inscrit:
    5 Juin 2006
    Messages:
    16 371
    J'aime reçus:
    2
    Tu as des sites qui sont développés à l'ancienne et qui ne marchent plus en php > 4
     
  8. Blount
    Blount WRInaute impliqué
    Inscrit:
    18 Novembre 2010
    Messages:
    707
    J'aime reçus:
    0
    D'une version PHP à une autre, des choses sont ajoutées, modifiées, supprimées ou indiquées comme "prochainement supprimé" (deprecated).

    Comme la doc PHP est une mine d'or, il suffit de prendre ta version actuelle de PHP (ex: 5.3), de prendre la version cible (ex: 5.6), et enfin de lire les notes de migration sur cette page :
    http://php.net/manual/fr/appendices.php

    Si tu n'es pas développeur, il faut alors mettre à jour ton logiciel CMS (si c'en est un) ou demander au développeur de ton site de réaliser la migration du code.
     
  9. walking7
    walking7 WRInaute passionné
    Inscrit:
    17 Février 2009
    Messages:
    1 556
    J'aime reçus:
    7
    merci de votre aide sympa,

    J'ai une trentaine de CMS wordpress est à jour dessus et 5 sites code un peu à l'ancienne.. Ils étaient tous en 5.4 et un seul en 5.2. Depuis que je suis passé en 5.6 sur tous ces sites, je n'ai pas remarqué de problème apparent.
    Ce que je veux dire c'est que si y'avait des problèmes je le verrai en naviguant sur mes sites ? .. ou pas forcément ?
     
Chargement...
Similar Threads - Migration PHP Forum Date
Migration site PHP vers Gatsby : quelques questions Problèmes de référencement spécifiques à vos sites 22 Août 2019
Quelle solution de forum utiliser pour migration phpbbseo ? Demandes d'avis et de conseils sur vos sites 11 Mars 2018
Migration forum phpbb vers vanilla 2 URL Rewriting et .htaccess 15 Février 2016
Migration php 5,5 à 5,6 = accents tronqués Développement d'un site Web ou d'une appli mobile 5 Mars 2015
En vue d'une migration sous PHP 6 Développement d'un site Web ou d'une appli mobile 17 Février 2010
Migration vers PHP4 à PHP5 Développement d'un site Web ou d'une appli mobile 9 Avril 2009
WordPress Migration de localhost vers nom de domaine + hébergement OVH Demandes d'avis et de conseils sur vos sites 28 Novembre 2019
Search Console Migration Google Search Console Référencement Google 24 Novembre 2019
Mysql migration utf8->utf8mb4 Développement d'un site Web ou d'une appli mobile 17 Août 2019
Migration boutique Problèmes de référencement spécifiques à vos sites 2 Juillet 2019
  1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies.
    Rejeter la notice