problème css IE != firefox

hanjy

Nouveau WRInaute
Bonjour bonjour. En ce moment j'essaye de faire un design pour un site.

à l'adresse suivante : hanjy.fr/eden

le problème c'est que sous firefox les ajustements sont bons. Mais que sous IE Il y a plusieurs bugs du genre
marges trop grandes
div qui s'en vont autre part dans la page (problème de positionnement)

j'avoue que je commence seulement à me mettre aux div donc si vous avez une solution.... ça ne serait pas de refus ma foi !

Le logo a également des problèmes de Z. Le texte passe derrière la barre transparente alors que celle ci a un Z inférieur au logo au titre et au slogan.

J'ai également entendu parler des commentaires conditionnels, qui activeraient une seconde feuille de style si le navigateur utilisé est IE mais je n'arrive pas vraiment à les faire fonctionner. quelqu'un pourrait me détailler leur fonctionnement ... ?
 

ZelkiN

WRInaute occasionnel
concernant des div n'oublie pas les margin meme et surtout si elles sont égales a 0

Concernant les Z-index si tu as du flash c'est un peu plus délicat, autrement il ne devrait pas y avoir de souci

Si tu as du flash il faut que tu mette un <param wmode="opaque"> il me semble. A verifier ;)
 

hanjy

Nouveau WRInaute
ZelkiN a dit:
concernant des div n'oublie pas les margin meme et surtout si elles sont égales a 0

Concernant les Z-index si tu as du flash c'est un peu plus délicat, autrement il ne devrait pas y avoir de souci

Si tu as du flash il faut que tu mette un <param wmode="opaque"> il me semble. A verifier ;)

Tout d'abord merci pour ta réponse, je commence à corriger les problèmes par rapport aux margin ;)

maintenant que voulais tu dire par rapport aux Z-index et au flash ? Quel est le problème exactement ?
Le flash perturberait les Z-index d'autres div ?
 

malvina14

WRInaute discret
hanjy a dit:
ZelkiN a dit:
concernant des div n'oublie pas les margin meme et surtout si elles sont égales a 0

Concernant les Z-index si tu as du flash c'est un peu plus délicat, autrement il ne devrait pas y avoir de souci

Si tu as du flash il faut que tu mette un <param wmode="opaque"> il me semble. A verifier ;)

Tout d'abord merci pour ta réponse, je commence à corriger les problèmes par rapport aux margin ;)

maintenant que voulais tu dire par rapport aux Z-index et au flash ? Quel est le problème exactement ?
Le flash perturberait les Z-index d'autres div ?

c'est l"inverse, pour un z-index sur du flash, il faut que le flash soit transparent.

Un id ne doit se trouver qu'une seule fois dans une page
Code:
<div id="barre"></div>
<div id="pos2">
	
	<div id="fond"><div id="barre"></div></div>
	<div id="logo"></div>
 

Vap

WRInaute impliqué
Commence par valider ton html et ton css:

http://validator.w3.org/check?verbose=1&uri=http://hanjy.fr/eden/
http://jigsaw.w3.org/css-validator/validator?profile=css21&warning=0&uri=http://hanjy.fr/eden/

Au moment où j'écris le CSS est bon mais pas le html.

La correction des erreurs ne gara,tit pas que tu n'aura pas de problème, mais ça aidera.

j'ajouterai

Code:
div {
margin: 0;
padding: 0;
}

dans ton css.

D'une manière générale il ne faut JAMAIS se reposer sur les valeurs par défaut, car elles diffèrent d'un navigateur à l'autre.  Précise toujours tes marges et tes paddings.
 

Discussions similaires

Haut