Problème d'encodage...

Discussion dans 'Développement d'un site Web ou d'une appli mobile' créé par ygalr22, 2 Mars 2012.

  1. ygalr22
    ygalr22 WRInaute discret
    Inscrit:
    9 Janvier 2008
    Messages:
    127
    J'aime reçus:
    0
    Bonjour à tous,,
    Voilà, j'ai un sérieux problème sur lequel je me prends la tête depuis quelques temps. Après moult recherches et lectures, je m'en remet à vos lumières parce-que là, je sèche...

    Je reprends dans l'ordre:
    J'ai développé un site PHP/HTML sous eclipse que je souhaite héberger chez OVH (mutualisé)
    Après le transfert sur le ftp (via filezilla) j'ai une belle erreur:
    Le problème est que phpheader() n'est pas une fonction php. Après vérification je me suis rendu compte que mon fichier est enregistré sur une seule ligne.
    Du coup j'ai forcément une erreur puisque le début de mon code est le suivant:
    J'ai donc tout viré de mon hébergement pour effectuer quelques test.
    J'ai deux Fichiers:
    Créé sous eclipse (configuration de base)
    Créé sous notepad++ (encodé en utf-8)
    Quelque soit le fichier appelé j'ai toujours la même erreur:
    Lorsque j'ouvre ses deux fichier avec le bloc note de windows, ils sont tous les deux écrits sur une seule ligne.
    Je soupçonne donc un problème d'encodage, mais je n'arrive pas à comprendre ce que je doit faire.
    Une idée?
     
  2. spout
    spout WRInaute accro
    Inscrit:
    14 Mai 2003
    Messages:
    9 029
    J'aime reçus:
    291
    Les fichiers sont envoyés en binary ou en texte (cfr. ton client FTP) ?
     
  3. ygalr22
    ygalr22 WRInaute discret
    Inscrit:
    9 Janvier 2008
    Messages:
    127
    J'aime reçus:
    0
    Le type de transfert est automatique.
    En fait je pense que ca viens plutôt de mon éditeur (eclipse) car lorsque j'ouvre mes fichiers avec le bloc note ils sont déjà sur une seule ligne.
    Pourtant l'encodage d'eclipse (cp1252) ne devrait pas poser de problème.
    Je me demande si ce ne sont pas les retour chariot qui ne sont pas pris en compte ou un truc dans le genre...
     
  4. ygalr22
    ygalr22 WRInaute discret
    Inscrit:
    9 Janvier 2008
    Messages:
    127
    J'aime reçus:
    0
    Bon, méaculpa, c'était le type de transfert qui devait être réglé sur binaire dans filezilla. :mrgreen:
    Il me semblait pourtant avoir testé cette option.
    Problème réglé.
     
  5. zeb
    zeb WRInaute accro
    Inscrit:
    5 Décembre 2004
    Messages:
    12 192
    J'aime reçus:
    1
    fait attention a bien préciser l'encodage du projet sous éclipse (bouton de droite sur le projet) car par défaut elle prend l'encodage du filesystem de ton pc qui n'est pas forcement iso-8859-1
     
  6. Leonick
    Leonick WRInaute accro
    Inscrit:
    8 Août 2004
    Messages:
    19 414
    J'aime reçus:
    0
    ça risque de te poser pas mal de problèmes d'affichages, que ce soit en iso 8859 ou en utf8
     
Chargement...
Similar Threads - Problème encodage Forum Date
Problème d'encodage Développement d'un site Web ou d'une appli mobile 30 Janvier 2015
Problème d'encodage caractère Google+ 6 Août 2014
Problème encodage UTF-8 Problèmes de référencement spécifiques à vos sites 4 Octobre 2013
Problème d'encodage url les é devient %E9 URL Rewriting et .htaccess 22 Décembre 2011
Problème d'affichage des entrées SQL (encodage) Développement d'un site Web ou d'une appli mobile 16 Avril 2011
Problème encodage de mon Blog utf-8 et iso-latin Développement d'un site Web ou d'une appli mobile 13 Février 2011
Analyse des balises meta problème d'encodage Développement d'un site Web ou d'une appli mobile 8 Février 2011
probleme d'encodage Développement d'un site Web ou d'une appli mobile 26 Octobre 2010
probleme encodage Développement d'un site Web ou d'une appli mobile 17 Avril 2010
Crawl ne dépasse pas la page d'accueil et semblant de problème d'encodage Administration d'un site Web 8 Mars 2010
  1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies.
    Rejeter la notice