Problème encodage iso et utf-8 Joomla 1.0.15

Discussion dans 'Développement d'un site Web ou d'une appli mobile' créé par agenceinternet, 15 Juin 2009.

  1. agenceinternet
    agenceinternet WRInaute passionné
    Inscrit:
    28 Mars 2008
    Messages:
    1 123
    J'aime reçus:
    0
    Bonjour,

    J'ai transféré un ancien site qui tournait sous joomla 1.0.15 sur mon nouveau serveur dédié, seulement l'ancien hébergement était en iso et mon nouveau serveur est en utf-8...

    Résultats j'ai de jolie problème... J'ai pu réparé les quelques pages du site en les modifiant une à la fois, mais le souci qui reste, c'est pour le formulaire de contact, car les message qui sont envoyé ont les accents qui bug... apparemment ils sont encodé en ISO, mais comme le serveur est en utf ils ne les lis pas et quand je recois les e-mail, tout les accents bugs.

    J'ai voulu voir en réinstallant joomla 1.0.15 dans un sous-dossier et là, j'ai directement laissé tombé, car tout les accents sous deja bugés, avant même l'installation...

    Est-ce que quelqu'un aurait une solution pour résoudre ce problème ???

    Soit indiquer à Joomla qu'il doit utiliser l'utf-8, soit pour permettre au serveur d'utiliser iso uniquement pour ce site (j'ai un serveur dédié avec Plesk 8.6 en utf-8) ?

    Merci d'avance pour votre aide !

    P.S.: Si jamais un exemple des bugs deja a l'installation : http://www.ericdanse.ch/test/installation/index.php et pour le site j'ai corrigé, mais le formulaire de contact ne fonctionne pas : http://www.ericdanse.ch
     
  2. datch
    datch WRInaute impliqué
    Inscrit:
    16 Juin 2006
    Messages:
    895
    J'aime reçus:
    1
    bonsoir

    As tu essayé de modifier ton htaccess afin de modifier l'iso?
     
  3. agenceinternet
    agenceinternet WRInaute passionné
    Inscrit:
    28 Mars 2008
    Messages:
    1 123
    J'aime reçus:
    0
    bonne question, mais là j'avoue ne pas savoir quoi faire... On peut changer l'encodage via un code dans le htaccess ???
     
  4. datch
    datch WRInaute impliqué
    Inscrit:
    16 Juin 2006
    Messages:
    895
    J'aime reçus:
    1
    oui tu peux changer le charset via htaccess
    essais ça

    AddDefaultCharset UTF-8

    OU

    AddDefaultCharset ISO-8859-1
     
  5. agenceinternet
    agenceinternet WRInaute passionné
    Inscrit:
    28 Mars 2008
    Messages:
    1 123
    J'aime reçus:
    0
    merciiiiiiiiiiiiiiiiiiiiiiii !!!!!

    Ca marche parfaitement en mettant tout simplement un htaccess avec dedans :

    AddDefaultCharset ISO-8859-1


    Merci bcp pour ton aide !!! C'est excellent de pouvoir gérer l'encodage via un htaccess ! Encore merci !
     
  6. datch
    datch WRInaute impliqué
    Inscrit:
    16 Juin 2006
    Messages:
    895
    J'aime reçus:
    1
    De rien
    J'ai eu le même problème la semaine dernière, c'est vraiment galère les isos.
     
  7. agenceinternet
    agenceinternet WRInaute passionné
    Inscrit:
    28 Mars 2008
    Messages:
    1 123
    J'aime reçus:
    0
    Eh eh, oui c'est le cas de le dire, c'est vraiment la galère ces encodage...

    Encore merci pour ton aide !!!! :mrgreen:
     
Chargement...
Similar Threads - Problème encodage iso Forum Date
Problème encodage de mon Blog utf-8 et iso-latin Développement d'un site Web ou d'une appli mobile 13 Février 2011
Problème d'encodage Développement d'un site Web ou d'une appli mobile 30 Janvier 2015
Problème d'encodage caractère Google+ 6 Août 2014
Problème encodage UTF-8 Problèmes de référencement spécifiques à vos sites 4 Octobre 2013
Problème d'encodage... Développement d'un site Web ou d'une appli mobile 2 Mars 2012
Problème d'encodage url les é devient %E9 URL Rewriting et .htaccess 22 Décembre 2011
Problème d'affichage des entrées SQL (encodage) Développement d'un site Web ou d'une appli mobile 16 Avril 2011
Analyse des balises meta problème d'encodage Développement d'un site Web ou d'une appli mobile 8 Février 2011
probleme d'encodage Développement d'un site Web ou d'une appli mobile 26 Octobre 2010
probleme encodage Développement d'un site Web ou d'une appli mobile 17 Avril 2010
Crawl ne dépasse pas la page d'accueil et semblant de problème d'encodage Administration d'un site Web 8 Mars 2010
Problème d'encodage "é" en é ! Développement d'un site Web ou d'une appli mobile 6 Février 2010
Problème d'encodage? Développement d'un site Web ou d'une appli mobile 27 Janvier 2010
problème encodage Développement d'un site Web ou d'une appli mobile 19 Septembre 2009
Problème de fou avec parsage de flux xml traded*** et encodage utf8 en php Développement d'un site Web ou d'une appli mobile 16 Septembre 2009
[MYSQL/PHP] Probleme d'encodage et serialize Développement d'un site Web ou d'une appli mobile 22 Juin 2009
Problème d'encodage Développement d'un site Web ou d'une appli mobile 23 Mai 2009
Problème d'encodage de l'apostrophe ’ Développement d'un site Web ou d'une appli mobile 10 Avril 2009
Problème d'encodage Développement d'un site Web ou d'une appli mobile 23 Février 2009
Problème d'encodage... Développement d'un site Web ou d'une appli mobile 8 Novembre 2008