Problème migration de site internet

Discussion dans 'Administration d'un site Web' créé par rezocom, 2 Février 2015.

  1. rezocom
    rezocom Nouveau WRInaute
    Inscrit:
    2 Février 2015
    Messages:
    41
    J'aime reçus:
    0
    Bonjour,
    J'ai un souci, j'ai développé un site internet d'abord sur un sous domaine d'un autre site (sous la forme -http://test.monsite.com) et maintenant je veux tout migrer au propre sur -http://nouveausite.com
    J'ai donc copié tous les fichiers vers le nouveau dossier, j'ai édité la BDD, etc...
    Mais résultat sur -http://nouveausite.com, toute la mise en page CSS a sauté, les images aussi, et tous les liens des articles renvoient une page 404... comment régler ce problème ?
    Merci par avance de votre aide,
    Cordialement.
     
  2. p0k3
    p0k3 WRInaute occasionnel
    Inscrit:
    2 Juin 2010
    Messages:
    315
    J'aime reçus:
    0
    Tu as développé ton site avec quoi ? (Wordpress ? ...)

    Donne nous l'adresse du site en question pour voir ce que ça donne !
     
  3. detectimmobilier
    detectimmobilier WRInaute passionné
    Inscrit:
    21 Février 2009
    Messages:
    1 919
    J'aime reçus:
    0
    Bonjour,
    As tu lancé un recalcul des liens avant de publier ?
     
  4. rezocom
    rezocom Nouveau WRInaute
    Inscrit:
    2 Février 2015
    Messages:
    41
    J'aime reçus:
    0
    Merci de vos réponses.
    Oui avec Wordpress. Là le site est inactif, j'ai tout viré, puis il est tout en phase de développement...
    Non recalcul des liens, je connais pas kesako ?
    Au pire je peux refaire toutes les manips à la main sur une install neuve, ce qui sera peut etre aussi bien, mais j'aimerais bien comprendre en quoi j'ai fait une erreur, je serais moins bete... :D
     
  5. p0k3
    p0k3 WRInaute occasionnel
    Inscrit:
    2 Juin 2010
    Messages:
    315
    J'aime reçus:
    0
    Wordpress garde en BDD l'url de base de ton site...

    Et en général les navigateurs refusent les CSS externes.
    Donc à mon avis le HTML fait des références à des fichiers CSS sur l'ancien site !

    Tu peux modifier ça dans les paramètres de l'admin normalement !
     
  6. rezocom
    rezocom Nouveau WRInaute
    Inscrit:
    2 Février 2015
    Messages:
    41
    J'aime reçus:
    0
    En fait j'ai modifié la BDD "à la main" avec mon bloc note (comme elle est pas énorme), j'ai fait 2 types de modifs :

    rechercher
    http://test.monsite.com
    remplacer par
    http://nouveausite.com

    et pour spécifier les dossiers

    rechercher
    racine/test/
    remplacer par
    racine/nouveausite

    malgré cela les articles renvoient une 404...

    Dans l'admin ça serait où qu'il faudrait spécifier ?
     
  7. p0k3
    p0k3 WRInaute occasionnel
    Inscrit:
    2 Juin 2010
    Messages:
    315
    J'aime reçus:
    0
    Dans les paramètres généraux, je crois...

    quand je faisais des sites, j'avais tendance à faire ça pour linker mes CSS :

    /wp-includes/themes/<nom_du_theme>/styles.css
     
  8. rezocom
    rezocom Nouveau WRInaute
    Inscrit:
    2 Février 2015
    Messages:
    41
    J'aime reçus:
    0
    Là je comprends plus rien : je viens de refaire un test et tout semble marcher !
    Pourtant j'ai vraiment RIEN touché...
    A croire que la BDD s'est réparée tout seule ??? :lol:
    Je vais désactiver et refaire des tests...
     
  9. HiFi Guy
    HiFi Guy Nouveau WRInaute
    Inscrit:
    24 Juin 2007
    Messages:
    37
    J'aime reçus:
    0
    Ou peut-être un problème de cache :wink:
     
  10. rezocom
    rezocom Nouveau WRInaute
    Inscrit:
    2 Février 2015
    Messages:
    41
    J'aime reçus:
    0
    Bonsoir Hifi Guy,
    Il y a un cache dans la BDD ? là tu m'apprends un truc... mais là j'ai fait des tests, ça a l'air de marcher...
    Je ne comprends pas où était le probleme...
     
Chargement...
Similar Threads - Problème migration internet Forum Date
WordPress Problème indéxation suite à migration HTTP vers HTTPS Problèmes de référencement spécifiques à vos sites 31 Janvier 2019
Migration = Problème d'url non sélectionné comme canonique Crawl et indexation Google, sitemaps 14 Novembre 2018
Récapitulatif Problème avec Google Search Console suite à une migration Crawl et indexation Google, sitemaps 21 Septembre 2018
Problème de 1er octet très lent suite à migration d'un site vers https Problèmes de référencement spécifiques à vos sites 1 Mars 2017
Gros problème suite migration HTTPS Problèmes de référencement spécifiques à vos sites 31 Décembre 2016
Problème lié à une migration HTTPS Google Analytics 28 Avril 2016
Problèmes migration site Problèmes de référencement spécifiques à vos sites 27 Mars 2014
Problème de remontée balise Title suite à migration d'un site Crawl et indexation Google, sitemaps 6 Août 2013
Problème indexation google suite à migration Crawl et indexation Google, sitemaps 25 Juin 2013
Probleme de ref suite migration tumblr Problèmes de référencement spécifiques à vos sites 17 Juin 2011
  1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies.
    Rejeter la notice