Referencer forum phpbb --> probleme avec htaccess

fictif0113

WRInaute discret
Salut,

Lorsque j'essaie d'uploader le fichier htaccess, mon forum se retrouve indisponible.
Cependant j'ai fait comme décrit sur ce site internet, j'ai copier coller :

https://www.webrankinfo.com/dossiers/webmastering

Code:
 RewriteRule ^forum.* /forum/index.php

RewriteRule ^mforum([0-9]*).*
/forum/viewforum.php?f=$1&mark=topics

RewriteRule ^viewforum([0-9]*)-([0-9]*)-([0-9]*).*
/forum/viewforum.php?f=$1&topicdays=$2&start=$3

RewriteRule ^forum([0-9]*).*
/forum/viewforum.php?f=$1

RewriteRule ^ptopic([0-9]*).*
/forum/viewtopic.php?t=$1&view=previous

RewriteRule ^ntopic([0-9]*).*
/forum/viewtopic.php?t=$1&view=next

RewriteRule ^stopic([0-9]*)-([0-9]*).*
/forum/viewtopic.php?t=$1&watch=topic&start=$2

RewriteRule ^utopic([0-9]*)-([0-9]*).*
/forum/viewtopic.php?t=$1&unwatch=topic&start=$2

RewriteRule
^ftopic([0-9]*)-([0-9]*)-([a-zA-Z]*)-([0-9]*).*
/forum/viewtopic.php?t=$1
&postdays=$2&postorder=$3&start=$4

RewriteRule ^ftopic([0-9]*)-([0-9]*).*
/forum/viewtopic.php?t=$1&start=$2

RewriteRule ^ftopic([0-9]*).*
/forum/viewtopic.php?t=$1

RewriteRule ^ftopic([0-9]*).html
/forum/viewtopic.php?t=$1&start=$2&postdays=$3
&postorder=$4&highlight=$5

RewriteRule ^setopic_([0-9]*)-([a-zA-Z0-9]*).*
/forum/viewtopic.php?t=$1&highlight=$2

RewriteRule ^sutra([0-9]*).*
/forum/viewtopic.php?p=$1

( Mon forum est hébérgé sur OVH )

J'ai donc copier coller ceci dans wordpad, j'ai enregistré en xx.htaccess, j'ai uploader le fichier sur mon serveur et une fois sur le serveur j'ai renommer en .htaccess

Je ne comprend pas ou est l'erreur, pouvez vous me guider ?

Pour info j'ai bien mis ce .htaccess a la racine de mon forum.
Il se trouve dans http://www.xxx.com/forum


Merci
 

fictif0113

WRInaute discret
Salut,


Merci pour ta réponse.
Cependant ça ne marche pas :'(

Code:
RewriteEngine on
RewriteRule ^forum.* /forum/index.php

RewriteRule ^mforum([0-9]*).*
/forum/viewforum.php?f=$1&mark=topics

RewriteRule ^viewforum([0-9]*)-([0-9]*)-([0-9]*).*
/forum/viewforum.php?f=$1&topicdays=$2&start=$3

RewriteRule ^forum([0-9]*).*
/forum/viewforum.php?f=$1

RewriteRule ^ptopic([0-9]*).*
/forum/viewtopic.php?t=$1&view=previous

RewriteRule ^ntopic([0-9]*).*
/forum/viewtopic.php?t=$1&view=next

RewriteRule ^stopic([0-9]*)-([0-9]*).*
/forum/viewtopic.php?t=$1&watch=topic&start=$2

RewriteRule ^utopic([0-9]*)-([0-9]*).*
/forum/viewtopic.php?t=$1&unwatch=topic&start=$2

RewriteRule
^ftopic([0-9]*)-([0-9]*)-([a-zA-Z]*)-([0-9]*).*
/forum/viewtopic.php?t=$1
&postdays=$2&postorder=$3&start=$4

RewriteRule ^ftopic([0-9]*)-([0-9]*).*
/forum/viewtopic.php?t=$1&start=$2

RewriteRule ^ftopic([0-9]*).*
/forum/viewtopic.php?t=$1

RewriteRule ^ftopic([0-9]*).html
/forum/viewtopic.php?t=$1&start=$2&postdays=$3
&postorder=$4&highlight=$5

RewriteRule ^setopic_([0-9]*)-([a-zA-Z0-9]*).*
/forum/viewtopic.php?t=$1&highlight=$2

RewriteRule ^sutra([0-9]*).*
/forum/viewtopic.php?p=$1

Il mets une sorte d'erreur 500 ou il faut contacter l'administrateur .
Je ne vois pourtant pas ce qui cloche
 

totoro

WRInaute impliqué
Essaye déjà avec une seule règle pour débugger.

Tu dois en avoir une foireuse... upload les petit à petit.

Sinon je te conseille de rajouter la commande [L] à la fin de chaque ligne, qui te permet l'arret du traitement du fichier quand un regle est trouvée. Ca chargera moins ton serveur.
 

fictif0113

WRInaute discret
Code:
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, tech@ovh.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Ouai même en ne mettant que les deux premieres lignes j'açi ça :/
 

Discussions similaires

Haut