Problème d'encodage "é" en é !

Discussion dans 'Développement d'un site Web ou d'une appli mobile' créé par f4b06, 6 Février 2010.

  1. f4b06
    f4b06 Nouveau WRInaute
    Inscrit:
    2 Septembre 2008
    Messages:
    37
    J'aime reçus:
    0
    Bonjour à tous les membres de la communauté WRI !

    Je voulais savoir si vous pouviez m'aider à résoudre un léger problème d'accents...

    Je m'explique : depuis 2 jours, et après quelques modifications apportées sur mon site, qui est entièrement encodé en UTF-8, les caractères accentués sont mal interprétés par les outils de test de référencement en ligne (outiref, spider-simulator, rankingtoday, etc).

    Les "é" qui deviennent des é etc. Des caractères accentués qui ont l'air de ne pas être bien interprétés...

    Cependant dans mon navigateur tout semble correct quand la détection automatique de l'encodage est activée dans IE ou Firefox, aucun problème d'affichage.

    J'ai l'impression que soit ces outils en ligne ne prennent pas en compte l'encodage de la page et extraient les données en ISO plutôt que en UTF-8 (je constate le même affichage des caractères accentués "é" en é par exemple si je sélectionne ISO-8859-1 dans mon navigateur WEB au lieu de UTF-8 ou de laisser sur "détection automatique").

    Voici la configuration du header du site au niveau des déclarations d'encodage :

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" lang="fr">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

    Toutes les pages du site sont déclarées et enregistrées (avec dreamwaver pour info) en UTF-8 sans BOM et les caractères accentués sont écrits "en dur" dans le site... que des "é, à, è, ç" et pas de &eacute; ou autres.

    Je me tourne vers vous en espérant que vous pourrez m'apporter une piste qui pourra m'aider à contourner ce problème qui commence légèrement à m'énerver :)

    J'espère également que Google arrive à identifier ce problème d'encodage et que mes mots-clés accentués sont correctement orthographiés dans leur index...

    Merci d'avance pour votre aide,
    Fabien.
     
  2. Toma
    Toma WRInaute discret
    Inscrit:
    18 Janvier 2006
    Messages:
    217
    J'aime reçus:
    0
    Ne t'inquiète pas Google a un script plus développé que celui des annuaires :lol:

    Si tu veux que les annuaires recopient bien ta description et tes mots clés, mets ton texte à ces endroits avec les codes html (&blabla;).
     
  3. f4b06
    f4b06 Nouveau WRInaute
    Inscrit:
    2 Septembre 2008
    Messages:
    37
    J'aime reçus:
    0
    Merci Toma pour ta réponse mais ça ne réponds pas vraiment à mon problème :)

    En fait je voulais savoir pourquoi mon site était vue avec des caractères ISO plutôt que UTF-8 alors que tout est normalement déclaré en UTF-8 ! j'ai remarqué cela en essayant des outils SEO comme spider-simulator ou outilref, webconfs, etc qui me resortent tous des caractères accentués "foireux"... :s

    J'ai comparé avec d'autres sites UTF-8 qui utilisent des é, à, à dans leur contenu textuel, avec ces outils SEO et les accents sont correctement affiché dans les résultats d'analyse des outils...
     
  4. Toma
    Toma WRInaute discret
    Inscrit:
    18 Janvier 2006
    Messages:
    217
    J'aime reçus:
    0
    Si tu as trouvé des sites en UTF-8 qui apparaissent correctement dans les outils SEO dont tu parles (par exemple) je veux bien voir parce que le mien apparait avec des "é". Et google affiche pourtant ma description dans ses résultats avec un beau "é".

    Certains sites de SEO et annuaires ne regardent pas la balise "Content-Type" et scannent les sites en ISO (comme tu l'avais suggére), c'est pour ça qu'ils affichent les mauvais caractères. Ça n'est pas du tout un problème avec ton site, et comme je le disais google et compagnie lisent très bien les sites en UTF-8.

    Si ça t'embête d'avoir des caractères moches dans les outils SEO mets les codes html à la place des caractères spéciaux. Mais ça n'aura aucune incidence sur ton référencement. (Ça va juste un peu alourdir le poids de tes pages)

    Si tu me montres des sites en UTF-8 bien scannés par les outils que tu nommes je m'inclinerai, mais je demande à voir ! :)
     
  5. f4b06
    f4b06 Nouveau WRInaute
    Inscrit:
    2 Septembre 2008
    Messages:
    37
    J'aime reçus:
    0
    Merci Toma cette réponse me va à ravir :D

    Heuuu pourtant oui oui j'en ai vu et j'ai constaté moi-même que les quelques-uns que j'ai testé n'ont pas de problèmes d'accents dans ces mêmes outils... chelou chelou ^^
     
  6. Toma
    Toma WRInaute discret
    Inscrit:
    18 Janvier 2006
    Messages:
    217
    J'aime reçus:
    0
    Mais peut-être que je me trompe (et du coup une solution m'intéresserait).
    Tu pourrais pas donner quelques URL de sites que tu as testés ? Tu me fais douter ! :wink:

    Et peut-être quelqu'un d'autre peut confirmer ce que je dis ?
     
Chargement...
Similar Threads - Problème encodage é Forum Date
Problème d'encodage Développement d'un site Web ou d'une appli mobile 30 Janvier 2015
Problème d'encodage caractère Google+ 6 Août 2014
Problème encodage UTF-8 Problèmes de référencement spécifiques à vos sites 4 Octobre 2013
Problème d'encodage... Développement d'un site Web ou d'une appli mobile 2 Mars 2012
Problème d'encodage url les é devient %E9 URL Rewriting et .htaccess 22 Décembre 2011
Problème d'affichage des entrées SQL (encodage) Développement d'un site Web ou d'une appli mobile 16 Avril 2011
Problème encodage de mon Blog utf-8 et iso-latin Développement d'un site Web ou d'une appli mobile 13 Février 2011
Analyse des balises meta problème d'encodage Développement d'un site Web ou d'une appli mobile 8 Février 2011
probleme d'encodage Développement d'un site Web ou d'une appli mobile 26 Octobre 2010
probleme encodage Développement d'un site Web ou d'une appli mobile 17 Avril 2010
Crawl ne dépasse pas la page d'accueil et semblant de problème d'encodage Administration d'un site Web 8 Mars 2010
Problème d'encodage? Développement d'un site Web ou d'une appli mobile 27 Janvier 2010
problème encodage Développement d'un site Web ou d'une appli mobile 19 Septembre 2009
Problème de fou avec parsage de flux xml traded*** et encodage utf8 en php Développement d'un site Web ou d'une appli mobile 16 Septembre 2009
[MYSQL/PHP] Probleme d'encodage et serialize Développement d'un site Web ou d'une appli mobile 22 Juin 2009
Problème encodage iso et utf-8 Joomla 1.0.15 Développement d'un site Web ou d'une appli mobile 15 Juin 2009
Problème d'encodage Développement d'un site Web ou d'une appli mobile 23 Mai 2009
Problème d'encodage de l'apostrophe ’ Développement d'un site Web ou d'une appli mobile 10 Avril 2009
Problème d'encodage Développement d'un site Web ou d'une appli mobile 23 Février 2009
Problème d'encodage... Développement d'un site Web ou d'une appli mobile 8 Novembre 2008