Problème validation META-TAGS description et keywords

aherve

Nouveau WRInaute
Bonjour,

Je rencontre un problème de validation de mes META-TAGS description et keywords pour ma page d'accueil ( http://www.jobsncv.com ). En fait, j'obtiens des résultats différents avec chaque utilitaire de validation.

Lorsque j'utilise l'utilitaire proposé par outiref, ces deux tags apparaissent vides ( http://www.outiref.com ).
Lorsque j'utilise l'utilitaire http://analysis.freeurl.com ils ne sont pas vides mais sont tronqués à partir du premier apostrophe.
Lorsque j'utilise l'utilitaire http://www.theemiratesnetwork.com/compu ... alyzer.htm ou encore l'utilitaire http://www.yook.de/webmaster/meta_gen/ mes tags apparaissent normalement.

De plus, lorsque j'inscris mon site dans des annuaires mylinea, la description et les mots-clés ne sont pas automatiquement rapatriés.

Que dois-je en conclure ? Dois-je selon vous modifier quelque chose dans mes tags ?

Merci de votre aide.

Anthony
 

mike006

WRInaute occasionnel
Lorsque j'utilise l'utilitaire http://analysis.freeurl.com ils ne sont pas vides mais sont tronqués à partir du premier apostrophe.
Idem pour moi.

J'avais remarqué sur outiref sur un autre site que le mien que ces balises n'étaient pas validées quand écrites comme ça : <meta content ="blablabla" name description>
Il faut faire je crois :
<meta name="description" content="blablabla">
 

aherve

Nouveau WRInaute
Merci de vos réponses.

Voici le contenu exact de ma feuille de style (jusqu'à la fin de head). Je ne comprends vraiment pas pourquoi les attributs name et content sont inversés au final en xhtml ?

<?xml version="1.0" encoding="ISO-8859-1"?>

<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0" xmlns:i18n="http://apache.org/cocoon/i18n/2.1">

<xsl:include href="../../ressources/preenteteaccueil.xsl"/>
<xsl:include href="../../ressources/entete.xsl"/>
<xsl:include href="images_accueil.xsl"/>
<xsl:include href="rubriques_accueil.xsl"/>
<xsl:include href="../../ressources/piedaccueil.xsl"/>
<xsl:include href="formulaire.xsl"/>

<xsl:template match="/">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=ISO-8859-1" />
<title>jobsncv.com - l'emploi informatique - IT jobs</title>
<meta name="keywords" content="emploi informatique, IT jobs, offres d'emploi informatique, offres d'emploi, jobs, offre d'emploi, job, jobsncv.com, recrutement informatique, IT recruitment, annonces informatique, recherche emploi, search job, emploi, informatique, IT, offres, annonces, recrutement, CDI, carrière, career, base cv, cv database, cv, recruter" />
<meta name="description" content="Offres d'emploi dans l'informatique en Europe - IT jobs in Europe - Boostez votre carrière avec jobsncv.com : cv et candidature en ligne - Boost your career with jobsncv.com - cv and application online" />
<link rel="stylesheet" href="/cocoon/jobboard/css.css" type="text/css" title="css"/>
</head> ...
 

mrik

WRInaute discret
je ne crois pas que l'ordre des balises est un effet quelconque, mais si on veut être rigoureux, il faudrait écrire comme ça :
Code:
<meta content="blablabla" name="description" />
car seul l'attribut content est obligatoire dans la balise meta, le reste étant facultatif
 

aherve

Nouveau WRInaute
Il s'agissait bien d'un problème d'ordre des attributs (content doit effectivement être avant name) . La validation est ok désormais.
Merci beaucoup.
Anthony
 

Discussions similaires

Haut