1&1 mutualisé : erreur 500 et problème DSA host key

hibou57

WRInaute passionné
Je viens de m’apercevoir que deux sites sont KO chez moi, et renvoient une erreur 500, j’ignore depuis combien de temps, mais ça fonctionnait encore tôt ce matin.

J’ai voulu me connecter en SSH pour vérifier les logs d’erreur et la configuration, mais c’est KO aussi, j’obtiens ce message :

Code:
ssh uXXXXXXXX@sXXXXXXXXX.onlinehome.fr
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
@    WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED!     @
@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
Someone could be eavesdropping on you right now (man-in-the-middle attack)!
It is also possible that a host key has just been changed.
The fingerprint for the DSA key sent by the remote host is
xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx.
Please contact your system administrator.
Add correct host key in /home/xxxxxxx/.ssh/known_hosts to get rid of this message.
Offending DSA key in /home/xxxxxxx/.ssh/known_hosts:x
  remove with: ssh-keygen -f "/home/xxxxxxx/.ssh/known_hosts" -R sXXXXXXXXX.onlinehome.fr
DSA host key for sXXXXXXXXX.onlinehome.fr has changed and you have requested strict checking.
Host key verification failed.

Dois‑je mettre à jour known_hosts ou pas ? Est‑ce une attaque ou pas ?
 

hibou57

WRInaute passionné
J’ai quand‑même put consulter les logs d’accès en passant par -http://sXXXXXXXXX.onlinehome.fr/logs/ et en m’identifiant. Les erreurs 500 sont systématique depuis 13h37. Malheureusement, pas de logs d’erreur.
 

hibou57

WRInaute passionné
Toujours pas de réponse de 1&1.

Je fais quoi ? Je met à jour known_hosts sans aucune manière de savoir si l’emprunte a changé, genre je joue à la loterie ?

L’erreur 500 persiste, aucun moyen de savoir ce qui ne va pas, ni de corriger.


1&1 ça va quand il n’y a pas de problème, mais en cas de problème, c’est la galère. Rien, aucun moyen de savoir ni vérifier quoique ce soit, même pas de log d’erreur Apache, nada.
 

hibou57

WRInaute passionné
Drew a dit:
Tu auras du mal a avoir une réponse ici sur un problème du coté de 1&1 (a priori).
Je me disais que peut‑être quelqu’un saurait ici, comme je n’ai pas de réponse ailleur après avoir cherché partout.

Drew a dit:
0970 808 911 (non surtaxé)
7j/7, 24h/24
Ça ne marche pas. Je tape 1, comme je suis déjà client. Ça me demande d’entrer mon numéro de client, ce que je fais, et ça me dit que mon choix n’est pas correcte.

Je leur ai envoyé un mail, mais je n’ai toujours pas de réponse.

Je suis complétement bloqué, je ne peux rien faire, comme je n’ai pas d’accès SSH. Et je n’ose pas mettre à jour known_hosts, comme je ne sais pas s’il y a un problème d’interception entre les deux. Sans compter la spécialité de 1&1 : pas d’accès aux logs d’erreurs Apache.
 

hibou57

WRInaute passionné
J’ai put appeler, j’avais confondu le numéro de contrat et le numéro de client :oops: .

Je ne sais pas si je me suis bien exprimé, j’ai l’impression que le problème n’a pas été compris, et en plus, on m’a dit qu’il n’y a pas de trace du mail envoyé aujourd’hui. Quelqu’un me rappellera demain à 17h.

J’aimerais corriger ce problème avant, parce que sinon la cata avec l’indexation Google (demain à 17h, ça fera 28h d’erreurs 500), déjà que les revenus publicitaires sont catastrophiques …

Pour le moment, ça n’avance pas, je ne sais toujours pas si l’identification de l’hôte SSH a simplement changé de leur côté ou si c’est une attaque man‑in‑the‑middle.
 

hibou57

WRInaute passionné
Drew a dit:
Si tu as l'accès FTP qui fonctionne vire ton php.ini et ton .htaccess (si tu en as) juste pour voir si cela change quelque chose.

[…]
Le FTP classique ne fonctionne plus, il n’y a plus que le SFTP qui pose le même problème que la SSH, vu que l’authentification est la même.

Je me suis rabattu sur un FTP web proposé par 1&1. Depuis l’espace client, aller dans « Hébergement », puis dans «Gérer l’espace web  » aller dans « 1&1 WebTransfert ».

Ça ne permet pas l’édition il faut télécharger, éditer, charger, à chaque modification.

J’ai put corriger le problème web en identifiant ce qui provoquait l’erreur 500. Ces deux options ne semble plus supportées dans les .htaccess sur les mutualisés :

  • Options -ExecCGI
  • Options -Includes

La configuration de Apache a dut changer (dans la configuration Apache, on peut limiter les options utilisables dans un .htaccess). Mais comme on ne peut pas non‑plus la consulter, il faut toujours jouer aux devinettes en tâtonnant … :roll:

Au moins c’est déjà ça de corrigé. Reste à régler le problème de l’identification SSH (pour demain ou plus tard).


Merci Drew, pour tes réponses :) , et Spout, pour ton passage :p .
 

hibou57

WRInaute passionné
Pour le problème de connexion SSH et SFTP, je viens d’avoir la réponse après avoir été rappelé (*).

Le nom d’hôte a changé. Avant ils étaient de la forme sXXXXXXXXX.onlinehome.fr, maintenant ils sont de la forme uXXXXXXXX.1and1-data.host. D’après ce qu’il m’a dit, la modification date d’il y a déjà un mois. Pour une raison que j’ignore, ça a continué à fonctionner après chez moi. Je n’avais pas non‑plus reçu de mail m’en avertissant (ce que j’ai fait remarquer).

Il faut nettoyer l’ancien know_hosts avec ces deux commandes :
Code:
ssh-keygen -R sXXXXXXXXX.onlinehome.fr  # Nom de l’hôte
ssh-keygen -R XXX.XXX.XXX.XXX  # IP de l’hôte, normalement indiquée par un message d’erreur

(*) Une chose drôle, est que c’est le service des serveurs dédiés qui m’a appelé pour me donner la réponse, alors que je suis en mutualisé.
 

hibou57

WRInaute passionné
Maintenant c’est le serveur SQL qui est KO, depuis 14h aujourd’hui environ :roll:

— Édit à 16h49 —

C’est bon, ça vient de revenir à l’instant.
 

Discussions similaires

Haut