Connexion Timeout et coupure répétée

Eric34

WRInaute discret
Bonjour,

J'ai un problème récurrent depuis plus d'une semaine sur un de mes sites. J'ai d'abord cru que le problème provenait du serveur et j'ai donc pris un serveur plus puissant mais ça ne venait visiblement pas de là...

Ce qu'il se passe c'est que toutes les heures environ (pas à intervalle régulier) j'ai des coupures de 3-5minutes (voir screen ci-dessous

trafic-trouble.jpg


J'ai retourné le problème dans tous les sens et je ne vois pas du tout mais alors pas du tout d'où ça peut venir...Quelqu'un aurait eu un problème de ce genre? J'aimerais savoir où chercher en fait, j'ai retourné mon theme, mes plugins, ma DB dans tous les sens, il semble pas y avoir de problème...Ca vient donc forcément de la conf du serveur non?

Merci de vos réponses ;)
 

Eric34

WRInaute discret
Bonjour, j'ai regardé Munin, mais j'hésite à l'installer, j'ai l'impression que c'est un outil compliqué que je vais passer des heures à configurer...Comme tu t'en doutes, je suis assez novice en la matière et j'ai un peu peur de faire n'importe quoi...
 

Julia41

WRInaute passionné
Ton image a disparu alors ça ne me parle pas trop.

Je verrais bien des soucis dans ta conf Apache (si tu l'utilises) au niveau des TimeOut et des KeepAlive...

Il faudrait aussi que tu regardes tes logs d'erreur Apache au moment de ces plantages, ça serait certainement plus parlant.

Fais-tu quelque chose pour que tes sites refonctionnent ?
 

Bool

WRInaute passionné
Moi j'aurais misé sur une saturation du conntrack (firewall), mais oui, sans logs on pioche au hasard.

Histoire de dégrossir, peux tu nous donner (copier/coller dans pastebin si trop gros) la sortie de ces deux commandes stp ?
Code:
cat /var/log/kern.log
Code:
grep -v 'File does not exist' /var/log/apache2/error.log | grep -v 'client denied by'

En espérant que tu sois sous Debian ou Ubuntu... si ce n'est pas le cas, peux-tu préciser le système que tu utilises stp ?
 

AnneGe

Nouveau WRInaute
Bonjour,

J'ai le même problème avec Debian, subitement du jour au lendemain, mon site répondait rarement
Dans error log, j'ai
mod_fcgid: read data timeout in 45 seconds
Premature end of script headers: index.php

J'ai augmenté
FcgidConnectTimeout 10000
FcgidIOTimeout 10000
Je n'ai plus d'erreur 500 mais la page met 20 secondes à se charger...

Je ne sais plus quoi faire et surtout savoir d'où vient le problème, de mon hébergeur ou de la configuration apache, sachant que cela fonctionnait très bien jusqu'alors ?

Merci pour vos réponses,
Franck
 

Bool

WRInaute passionné
Bonjour,

Commence par regarder les logs. S'il y a un problème hardware, ce sera probablement visiblement dans /var/log/kern.log.

Après, faut creuser... du peux par exemple activer les logs «slow queries» de MySQL pour voir si ça vient de là. Ou bien à minima installer «mytop» afin de voir ce qui se passe coté MySQL quand ces pages tournent.

Mais bon, il peut y avoir plein de causes possibles, faut surtout apprendre à regarder les logs & ressources du serveur, voir à débugger le code pour comprendre ce qu'il essaye de faire.
 

AnneGe

Nouveau WRInaute
Merci Bool pour toutes ces pistes.
Je vais explorer pour en savoir plus.

Les pages sans requete SQL s'affichent effectivement sans probleme,
je vais vérifier si cela est toujours vrai.
 

AnneGe

Nouveau WRInaute
J'ai aussi des erreurs 503

Dans les log je constate plein d'erreurs mysql
mod_fcgid: stderr: PHP Warning: mysql_close(): no MySQL-Link resource supplied in...
mod_fcgid: stderr: PHP Warning: mysql_connect(): Can't connect to MySQL server on...
mod_fcgid: stderr: PHP Warning: mysql_select_db(): Access denied for user...
mod_fcgid: stderr: PHP Warning: mysql_select_db(): A link to the server could
mod_fcgid: stderr: PHP Notice: Undefined index: ...

Par contre, s'il y a un problème de configuration, je ne comprends pas pourquoi parfois le site marche bien !
 

AnneGe

Nouveau WRInaute
Bonjour,

J'ai regardé les logs en détail et j'ai remarqué quelque chose de bizarre.
Par exemple :
mod_fcgid: stderr: PHP Warning: mysql_connect(): Can't connect to MySQL server on '62.193.209.24'
or cette adresse IP n'est pas l'adresse IP de mon serveur privé...
Quand je fais un ping sur mon nom de domaine, j'ai une autre adresse IP...

Il est là le bug ?
Merci pour vos réponses

PS : j'ai regardé les mysql slow log et toutes les requêtes sont lentes, même les requêtes sur des tables petites comprenant 30 données
 

AnneGe

Nouveau WRInaute
Bonjour,

Pour l'adresse IP, ça doit être normal puisque l'erreur ne venait pas de là.

En fait c'était un problème de CHMOD sur un dossier.
Probablement du à une mise à jour automatique du serveur puisque de notre côté on avait rien changé.

Pour ceux qui ont des lenteurs Mysql, peut être que cette info les aidera.

MERCI à Bool pour son conseil concernant les logs «slow queries» dont l'examen nous a permis de remonter au problème.

Franck
 

Discussions similaires

Haut