Fatal error sur Url absente

Discussion dans 'Problèmes de référencement spécifiques à vos sites' créé par elteor, 13 Mai 2016.

  1. elteor
    elteor WRInaute discret
    Inscrit:
    12 Novembre 2002
    Messages:
    87
    J'aime reçus:
    0
    Bonjour à tous

    Après plusieurs semaines de boulot et un changement de serveur j'ai lancé hier une analyse du site via l'audit Ranking metrics.
    Les résultats dans l'ensemble me paraissent plutot bon (mieux qu'avant en tout cas) mais bien évidemment il reste toujours des choses à corriger.
    J'ai commencé ce matin par la correction des Url répondant en erreur.
    Dans la liste que me fournit l'audit Rankin metrics j'ai quelques pages qui ont été supprimées et dont j'avais oublié de faire les redirection 301 que je viens d'ajouter dans le htaccess.

    Par contre (et c'est la mon soucis) j'ai une vingtaine d'url qui lorsqu’elles sont appelées répondent en erreur par un : Fatal error
    Ce sont des url de page correspondant à d'anciennes fiches produits qui ont été supprimées mais je ne vois rien de particulier dessus par rapport à d'autres fiches produits supprimées.

    De plus si j'ajoute ces url dans mon htaccess pour faire un 301 dessus alors cela met le serveur en erreur :(

    Mes questions :
    1 - Sauriez vous pourquoi certaines url sont en Fatal error ?
    2 - Avez vous une idée de la façon de corriger cela ?

    Merci d'avance pour votre aide.
     
  2. spout
    spout WRInaute accro
    Inscrit:
    14 Mai 2003
    Messages:
    8 739
    J'aime reçus:
    15
    Il faut consulter les logs du serveur HTTP et/ou ceux du CMS.
     
  3. elteor
    elteor WRInaute discret
    Inscrit:
    12 Novembre 2002
    Messages:
    87
    J'aime reçus:
    0
    Salut Spout et merci pour ta réponse rapide.

    Rien vu à ce niveau. Dans les log du cms le plus récent remonte à fin avril et n'a aucun rapport. Quant au journal d'erreur du serveur je ne vois rien non plus qui ressemble à un message concernant mon soucis (mais la j'avoue être moins à l'aise :) )
     
  4. spout
    spout WRInaute accro
    Inscrit:
    14 Mai 2003
    Messages:
    8 739
    J'aime reçus:
    15
    Tu as un exemple d'URL en fatal error ? Pour peut-être voir d'où ça vient.
     
  5. elteor
    elteor WRInaute discret
    Inscrit:
    12 Novembre 2002
    Messages:
    87
    J'aime reçus:
    0
    Yes

    deux exemples
    nom de domaine
    http://www.vapoteurs.com

    et avec la suite qui est
    /batterie-chargeur/499-chargeur-ultrafire-wf188.html
    /e-liquide-flavour-art/1006-soho.html

    Je mets pas les liens en une fois pour éviter que cela fasse des backlinks sur des urls en erreur :wink:
     
  6. spout
    spout WRInaute accro
    Inscrit:
    14 Mai 2003
    Messages:
    8 739
    J'aime reçus:
    15
    Ça semble être un "Fatal error" renvoyé par PrestaShit (si c'était le serveur HTTP, ce serait plutôt un HTTP 500 au lieu de 404).
    Donc faut regarder de ce côté là.
     
  7. elteor
    elteor WRInaute discret
    Inscrit:
    12 Novembre 2002
    Messages:
    87
    J'aime reçus:
    0
    ok merci.

    Vais essayer de regarder de ce coté la...