Interprétation des lettres accentuées dans les résultats de Google ?

Discussion dans 'Crawl et indexation Google, sitemaps' créé par marcp06, 22 Juin 2011.

  1. marcp06
    marcp06 Nouveau WRInaute
    Inscrit:
    12 Octobre 2006
    Messages:
    15
    J'aime reçus:
    0
    Bonjour,

    Alors voila un souci dont je n'arrive pas à trouver la solution :(

    Sur deux pages différentes mais faites de la même manière,
    voici ce que donne l'affichage dans les résultats de recherche sur Google :
    (que ce soit dans le titre ou la description)

    Pour une page il affiche les accents de façon normale comme ceci par exemple : " Créer "

    Et pour une autre page, il affiche : " Crйer "

    J'ai bien la même structure sur mes deux pages :

    Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
    <title>blabla créer</title>
    <meta name="description" content="blabla">
    <meta name="keywords" content="blabla">
    <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
    
    Voila,
    Si quelqu'un pouvait m'aider, ce serait bien sympa :)

    Merci
     
  2. e-kiwi
    e-kiwi WRInaute accro
    Inscrit:
    23 Décembre 2003
    Messages:
    13 257
    J'aime reçus:
    1
    avec pspad, regarde l'encodage du fichier, tu en a peut être un en iso, et l'autre en utf-8
     
  3. Marie-Aude
    Marie-Aude WRInaute accro
    Inscrit:
    5 Juin 2006
    Messages:
    16 361
    J'aime reçus:
    2
    Si on pouvait avoir l'adresse du site ça aiderait à aider... j'ai comme une petite idée que je voudrais vérifier :D
     
  4. marcp06
    marcp06 Nouveau WRInaute
    Inscrit:
    12 Octobre 2006
    Messages:
    15
    J'aime reçus:
    0
    Je ne suis pas ici pour faire de la publicité, c'est pour cela que je n'ai pas mis l'adresse
    Pour pspad, je vais voir car je ne connaît pas :?

    les adresses sont :
    mamethode.com/page-capture/page-capture-system
    c'est celle qui n'est pas bonne

    et celle qui est bonne :
    mamethode.com/page-capture/affiliation.php

    Je suis impatient de connaître ta petite idée Marie Aude :wink:
    Merci pour votre aide
     
  5. Leonick
    Leonick WRInaute accro
    Inscrit:
    8 Août 2004
    Messages:
    19 413
    J'aime reçus:
    0
    je ne vois aucun problème sur la page pas bonne. Du moins avec FF 5
     
  6. marcp06
    marcp06 Nouveau WRInaute
    Inscrit:
    12 Octobre 2006
    Messages:
    15
    J'aime reçus:
    0
    Bonjour Leonick,

    Hé oui, c'est ici mon souci, je ne trouve pas non plus.
    et surtout j'arrive pas à comprendre

    Comme disait Gérard Majax : Y a un truc ! :D

    Et sinon ... pas de nouvelle de Marie-Aude ?
    je suis surpris :? peut-être que finalement la petite idée n'était pas ça ... ;)
     
  7. Marie-Aude
    Marie-Aude WRInaute accro
    Inscrit:
    5 Juin 2006
    Messages:
    16 361
    J'aime reçus:
    2
    Tu as bien vérifié les formats de fichier source ?
     
  8. marcp06
    marcp06 Nouveau WRInaute
    Inscrit:
    12 Octobre 2006
    Messages:
    15
    J'aime reçus:
    0
    Je ne comprend pas bien ce que tu veux dire Marie Aude ?

    Si tu veux bien expliquer, merci
     
  9. Leonick
    Leonick WRInaute accro
    Inscrit:
    8 Août 2004
    Messages:
    19 413
    J'aime reçus:
    0
    quel encodage ont tes fichiers sources et tes base de données ? est-ce le même que celui envoyé par la page (iso 8859) ?
     
  10. Marie-Aude
    Marie-Aude WRInaute accro
    Inscrit:
    5 Juin 2006
    Messages:
    16 361
    J'aime reçus:
    2
    Je veux dire


     
  11. JanoLapin
    JanoLapin WRInaute accro
    Inscrit:
    21 Septembre 2008
    Messages:
    4 250
    J'aime reçus:
    0
    et puis vérifie aussi l'encodage sélectionné de tes navigateurs.... si ce n'est pas le même...
     
  12. marcp06
    marcp06 Nouveau WRInaute
    Inscrit:
    12 Octobre 2006
    Messages:
    15
    J'aime reçus:
    0
    Bonjour JanoLapin,

    sur les navigateurs, j'avais essayé :)

    Marie-Aude, pspad est un éditeur et perso j'utilise dreamwever
    bon peut être que ce n'est pas pareil mais bon
     
  13. Marie-Aude
    Marie-Aude WRInaute accro
    Inscrit:
    5 Juin 2006
    Messages:
    16 361
    J'aime reçus:
    2
    Et as tu regardé dans dreamweaver l'encodage de tes fichiers ?
     
  14. marcp06
    marcp06 Nouveau WRInaute
    Inscrit:
    12 Octobre 2006
    Messages:
    15
    J'aime reçus:
    0
    oui et c'est le même

    je vais faire un essai en mettant en UTF 8
    toutes façon, maintenant c'est ce qu'il faut faire d'office je crois
     
  15. Leonick
    Leonick WRInaute accro
    Inscrit:
    8 Août 2004
    Messages:
    19 413
    J'aime reçus:
    0
    non, pas obligé. En plus, comme tes pages sont envoyées en iso 8859, encoder tes pages en utf8 va augmenter les problèmes
     
  16. marcp06
    marcp06 Nouveau WRInaute
    Inscrit:
    12 Octobre 2006
    Messages:
    15
    J'aime reçus:
    0
    Leonick, je voulais dire que je change l'encodage dans les propriétés de dreamweaver,
    ce qui fait que tout est changé dans la page
    enfin, je l'ai pas encore fait et franchement je ne sais pas si je vais le faire

    Par contre c'est quand même fou de pas trouver où est le problème

    Je tacherais de passer plus de temps du coté de l'aide chez Google
    voir si quelqu'un à déjà eu le souci ou tout simplement s'il en parle
    quelque part en Français lol

    Merci à tous de votre participation

    Si jamais quelqu'un trouve, qu'il n'hésite pas à poster :wink:

    Bonne fin de journée
    Marc
     
  17. Marie-Aude
    Marie-Aude WRInaute accro
    Inscrit:
    5 Juin 2006
    Messages:
    16 361
    J'aime reçus:
    2
    Le caractère apparait en tant que tel dans la source.

    Alors
    - option 1 tu as copié le texte sur un site qui se protège avec cette technique particulièrement vicieuse
    - option 2 tu as un problème dans ta source dreamweaver. As tu des caractères spéciaux sans html entities ?
     
  18. Leonick
    Leonick WRInaute accro
    Inscrit:
    8 Août 2004
    Messages:
    19 413
    J'aime reçus:
    0
    option 3 : le texte a été écrit sur word puis copié/collé
     
  19. Marie-Aude
    Marie-Aude WRInaute accro
    Inscrit:
    5 Juin 2006
    Messages:
    16 361
    J'aime reçus:
    2
    C'est un sous cas de l'option 2 ça :)
     
  20. Leonick
    Leonick WRInaute accro
    Inscrit:
    8 Août 2004
    Messages:
    19 413
    J'aime reçus:
    0
    oui, mais comme il ne semble pas trop comprendre ces problème d'entities, autant bien préciser
     
  21. marcp06
    marcp06 Nouveau WRInaute
    Inscrit:
    12 Octobre 2006
    Messages:
    15
    J'aime reçus:
    0
    Pour la petite histoire, si vous regardez la source de la page " affiliation "
    c'est pareil, j'ai écris le titre et la déscription directement dans la source

    Au départ, j'avais mis (pour exemple) les " é " en " &eacute; "
    et quand j'ai vu que ce n'était pas bon, j'ai changé en mettant les lettres
    normal pour voir

    Non, j'ai la source

    Je ne fais jamais ça
    Si j'ai besoin de copier/coler, je passe par le bloc note :wink:

    Je ne suis pas expert c'est vrai, la preuve est que je ne trouve pas la solution,
    mais je comprend un peu quand même (ou presque)

    Par conte, je viens de voir que dans la source du cache qui est du
    17 juin, le " créer " est " Crйer "
    Je vais bientôt plus avoir de cheveux :lol:

    Je pense que dans certaines réponses, on s'écarte un peu :
    Le problème n'est pas sur la page ... la page visible c'est bon, le problème est seulement sur le titre et la description
    dans les résultats de recherche :wink:
     
  22. Marie-Aude
    Marie-Aude WRInaute accro
    Inscrit:
    5 Juin 2006
    Messages:
    16 361
    J'aime reçus:
    2
    Moi quand j'affichais la source je voyais les caractères cyrilliques. Si tu as changé depuis, il faut juste du temps pour que Google prenne en compte.
     
  23. marcp06
    marcp06 Nouveau WRInaute
    Inscrit:
    12 Octobre 2006
    Messages:
    15
    J'aime reçus:
    0
    Alors, le truc est que cela est toujours sur la même page :
    A chaque fois c'est sur la " squeeze page " du produit et non sur les autres

    J'ai donc cherché un peu du coté de la feuille de style par rapport aux classe de cette page seulement
    comme par exemple une classe " form ", que je n'ai que sur cette page, mais je n'est rien trouver de spécial
    à part la déclaration de la feuille de style qui est en UTF-8 ( @charset "utf-8"; )

    Mais bon, rien à voir avec le formulaire !
    Et c'est bien sûr cette même feuille de style qui sert au autres pages

    Je ne sais pas si je me suis bien expliqué :)
     
Chargement...
Similar Threads - Interprétation lettres accentuées Forum Date
Campagne vidéo : interprétation des vues à 100 % AdWords 21 Novembre 2017
Interprétation des balises <a> sans href Débuter en référencement 31 Mars 2017
Interprétation de l'état d'indexation de la Search console Crawl et indexation Google, sitemaps 10 Mars 2017
Interprétation du trust et citation flow de majestic Netlinking, backlinks, liens et redirections 12 Février 2017
Robots.txt : changement soudain d'interpretation par google Crawl et indexation Google, sitemaps 18 Février 2016
Interprétation des données Entonnoir Multi-canaux > Conversions Indirectes Google Analytics 30 Octobre 2015
Interprétation de données Débuter en référencement 31 Décembre 2013
Interprétation des stats Débuter en référencement 23 Janvier 2013
Problème Firefox 17 avec jQuery et interprétation de code JS Développement d'un site Web ou d'une appli mobile 23 Décembre 2012
Outil pour simuler l'interprétation des style CSS par Google bot Référencement Google 11 Juin 2012