[JOOMLA] Les accents ne s'affichent pas

Experter

WRInaute discret
Salut ,

Je posséde un site JOOMLA ( derniére version bien évidemment ) mais j'ai un petit probléme qui me géne un peut !

Dans la rubrique de recrutement , les accents et quelques lettres ne s'affichent pas ! ca devient comme ca par exemple :

accent aigu é ----------> é
accent grave è ---------> è
Ou � !

Dans la base de donnée c'est utf8_general_ci ! Je ne comprend pas comment regler ce probléme ! Que dois-je faire ?

Voila le lien : index.php?option=com_jobline&Itemid=340&task=view&id=1 ( celui qui veut que je lui donne l'adresse complète du site c'est par MP sans aucun problème ! )

Merci
Bonne journée
 

loran750

WRInaute passionné
hello

je peux te répondre !

C'est le fichier de langue française du composant (et non de Joomla) qui est différent du charset du site.
Style : tu as de l'UTF8 (en DOS ou en UNIX !!! attention, c'est différent), et ton fichier français n'est pas du même format que le fichier de langue française de Joomla.

--> Vérifie le format de ces 2 fichiers (par exemple avec Ultra Edit)

Lolo
 

Experter

WRInaute discret
à préciser que le composant fonctionne en mode légal, donc n'a pas été écrit pour joomla 1.5, alors que la base de donnée est UTF8

donc tu pense qu'on réecrivant le fichier de langue ça va fonctionner ?
 

loran750

WRInaute passionné
ça n'a rien à voir avec la BDD (à priori, sauf si le texte se trouve en BDD).
Non, c'est le fichier de langue du composant qui n'est pas au même format (UTF8 ou ISO***, UNIX ou DOS) que le format du fichier de langue de Joomla.

==>regarde le format du fichier de joomla et compare le à celui du composant.
 

Discussions similaires

Haut