Lenteurs serveur

Discussion dans 'Administration d'un site Web' créé par pspman80, 8 Février 2011.

  1. pspman80
    pspman80 WRInaute discret
    Inscrit:
    25 Février 2009
    Messages:
    59
    J'aime reçus:
    0
    Bonsoir, bonjour à tous,


    Je m'occupe de plusieurs sites webs avec lesquels j'ai jamais eu de soucis particuliers, mais aujourd'hui mon petit dernier m'embête un peu.
    Aujourd'hui le trafic du site a explosé ce qui m'a poussé a faire un peu de cache (je poursuivrais cela quand j'aurais un peu plus de temps).

    Il y a un cache sur l'accueil et sur chaque post, cache des pages donc.
    Il y a un autre cache pour les images redimensionnées à la volées (script TimThumb), cela dit les temps d'accès au fichier me paraissent énorme et je ne sais pas si ça l'est vraiment ou pas. Les images mettent entre 100 et 200ms chacunes à se charger alors qu'il est censé avoir un script de cache (qui semble bien le gérer d'ailleurs).

    Le site en question est ici: http://www.photos-non-contractuelles.fr

    Qu'en pensez-vous?

    Edit:

    J'ai fait le test d'un image en "dur" enregistrée à la racine du serveur:
    http://www.photos-non-contractuelles.fr/hachi_parmentier_casino_apres.jpg

    La même image qui passe dans la moulinette et qui est redimensionnée si pas en cache
    http://www.photos-non-contractuelles.fr/image.php?src=/medias/2011/02/ ... =292&h=292


    Les perfs sont les mêmes mais je les trouve lentes non?
     
  2. jcaron
    jcaron WRInaute accro
    Inscrit:
    13 Février 2004
    Messages:
    2 593
    J'aime reçus:
    0
    Je ne sais pas si ton système de cache fonctionne correctement ou pas, mais ton serveur est clairement (très, très) surchargé. C'est quoi comme serveur? Mutualisé? Dédié? Quelle config? Quel trafic?

    Si c'est un dédié, que disent "top" et "ps axl"? Que dit server-status (c'est un module Apache qu'il faut généralement activer dans la conf Apache)?

    Jacques.
     
  3. smorge
    smorge WRInaute occasionnel
    Inscrit:
    17 Juin 2009
    Messages:
    442
    J'aime reçus:
    0
    Tiens en passant... excellent ton site ! c'est une très bonne idée :)
     
  4. pspman80
    pspman80 WRInaute discret
    Inscrit:
    25 Février 2009
    Messages:
    59
    J'aime reçus:
    0
    J'utilise un Kimsufi (a 20€/mois) avec ispconfig et le script de cache semble bien tourner pourtant j'ai vérifié tout ça hier soir quand la charge été pas trop elevée.

    Lorsque je fais un top, rien d'alarmant à mon sens (j'ai pas mal de visiteurs connecté à l'heure ou je vous parle)
    [​IMG]

    Je ne comprends pas trop et ne suis pas expert en admin serveur
     
  5. jcaron
    jcaron WRInaute accro
    Inscrit:
    13 Février 2004
    Messages:
    2 593
    J'aime reçus:
    0
    Au moment où tu as fait le top, effectivement, a priori pas de souci.

    Il faudrait un "top" et un "ps axl" au moment où ton serveur met (beaucoup) de temps à répondre. Tout à l'heure c'était nettement plus de 10 secondes. Il faut aussi le résultat de server-status à ce moment-là. Et les parties concernant MaxClients et compagnie de ton httpd.conf. Sans ça, impossible de commencer à diagnostiquer le problème (il y a deux possibilités majeures: tu satures vraiment beaucoup le CPU, auquel cas il faut optimiser ou ajouter des caches, voire passer sur une machine plus puissante; ou tu satures simplement le nombre de processus Apache autorisés par la conf, ce qui peut quelquefois être résolu avec des modifs très mineures de la config).

    Jacques.
     
  6. pspman80
    pspman80 WRInaute discret
    Inscrit:
    25 Février 2009
    Messages:
    59
    J'aime reçus:
    0
    J'ai réglé le probleme (temporairement) qui semblait venir d'un virtualhost foireux.

    J'utilisais un sous domaine "medias.domaine.com" pour afficher les images et ca prenait beaucoup de temps, j'ai temporairement remis une url de type "domaine.com/medias" et ca respire déjà plus on dirait!
     
  7. jcaron
    jcaron WRInaute accro
    Inscrit:
    13 Février 2004
    Messages:
    2 593
    J'aime reçus:
    0
    Ca m'a juste l'air d'être une question de "charge" (sous une forme ou une autre) du serveur qui varie dans le temps. Il y a des moments où tout va très vite, d'autres où ça prend des plombes. C'est pour ça qu'il faut capturer les informations au moment où le problème est présent (et donc être prêt à le faire, donc que server-status soit déjà activé dans httpd.conf).

    Jacques.
     
  8. M&B Multimédia
    M&B Multimédia WRInaute passionné
    Inscrit:
    1 Octobre 2009
    Messages:
    1 117
    J'aime reçus:
    0
    Je confirme, rien à voir avec ce qu'il se passait tout à l'heure !

    PS : sympa le site !
     
  9. pspman80
    pspman80 WRInaute discret
    Inscrit:
    25 Février 2009
    Messages:
    59
    J'aime reçus:
    0
    J'analyserais ça ce soir. Merci de votre aide, je reviendrais aux nouvelles.
    Merci M&B Multimédia (interview ce soir sur Europe1 :) )
     
  10. Julia41
    Julia41 WRInaute passionné
    Inscrit:
    31 Août 2007
    Messages:
    1 779
    J'aime reçus:
    0
    Le script thumb.php est assez mauvais s'il n'est pas réécrit (la mise en cache se fait mal dans quelques cas).
    Ca pourrait aider.
    Si tu veux tester ça voir si tu as des temps d'accès meilleurs : -http://spcache.com/
    N'hésites pas (et si tu as besoin des sources aussi demandes moi) (le premier affichage est toujours long).

    A noter que les redimensionnements d'image/traitement sur un kim sont assez mauvais dû au processeur pas trop puissant.
     
  11. pspman80
    pspman80 WRInaute discret
    Inscrit:
    25 Février 2009
    Messages:
    59
    J'aime reçus:
    0
    Bonsoir à tous,

    Le probleme venait manifestement d'un virtualhost mal configuré le script de thumb qui s'appelle Timtumb (optimisé via quelques sources trouvées sur internet) tourne bien et mon système de cache aussi.
    Le serveur tient maintenant parfaitement la charge et le buzz!

    Merci à vous
     
Chargement...
Similar Threads - Lenteurs serveur Forum Date
Lenteurs d'indexation Google Crawl et indexation Google, sitemaps 18 Juin 2019
Problème de chargements JS et lenteurs Développement d'un site Web ou d'une appli mobile 6 Septembre 2013
Lenteurs avec php 5.3 Développement d'un site Web ou d'une appli mobile 18 Octobre 2011
Widgets facebook, lenteurs et cloaking Référencement Google 11 Février 2011
Safari ne peut pas établir de connexion sécurisée au serveur Demandes d'avis et de conseils sur vos sites 5 Mai 2020
Passer d'un hébergement mutualisé à serveur dédié Administration d'un site Web 24 Mars 2020
WordPress Hébergement - serveur dédié Le café de WebRankInfo 23 Mars 2020
Génération d'id unique - Plantage serveur Développement d'un site Web ou d'une appli mobile 6 Décembre 2019
Serveur adapté pour lecture vidéo sur pic de visiteurs Demandes d'avis et de conseils sur vos sites 2 Décembre 2019
Faire des 301 sans accès à son serveur : possible ? Développement d'un site Web ou d'une appli mobile 27 Novembre 2019
  1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies.
    Rejeter la notice