Mauvais sitemap statique déclaré

Discussion dans 'Crawl et indexation Google, sitemaps' créé par Altenide, 24 Juin 2019.

  1. Altenide
    Altenide WRInaute impliqué
    Inscrit:
    26 Novembre 2003
    Messages:
    528
    J'aime reçus:
    2
    Bonjour,

    Je voudrais savoir si quelqu’un a déjà été confronté à ce type de problème. Je viens d'analyser un site qui a subit une lourde chute de trafic. (de 1000 visites/jours à 100 visites/jours)

    Rien de très particulier hormis ceci :

    Lors de la création du site il y a 10 ans une déclaration de sitemap a été faite (6 URL). Ensuite le site à commencé a recevoir du contenu et des visites croissantes jusqu'en 2018, date a laquelle a été installé All in SEO. Et là le trafic a commené à s'écrouler.

    Mon explication :
    All in Seo a générer un sitemap.xml mais à un autre endroit. Ce dernier sitemap n'a pas été déclaré dans la Search Console qui est restée sur son sitemap d'origine (avec 6 url).

    Il y a donc eu un écart entre les urls déclarées (6) et les urls réellements présentes (une 50 taine) et cela a mis les crawlers en erreur, d'ou pb d'indexation, d'ou moins de visite sur le site.

    Ai-je raison selon vous ?

    merci
     
  2. Madrileño
    Madrileño Membre Honoré
    Inscrit:
    7 Juillet 2004
    Messages:
    32 136
    J'aime reçus:
    273
    Bonjour,

    Quand il y a un changement de ce genre, c'est souvent pour plusieurs raisons.
    Vous pouvez indiquer l'URL du site Internet pour des avis de la communauté d'entraide.

    Vous pouvez commencer par vérifier :
    - si vous avez un message via le Search Console de Google
    - avec les outils SC pour webmasters de Google disponibles
    - si ce n'est pas un problème avec la mise à jour récente de Google
    - les statistiques du site qui peuvent aussi expliquer certaines erreurs
    - les dernières modifications réalisées avec le site Internet
    .

    Temps de réponse : 10 minutes.
    Cordialement.
     
  3. rollback
    rollback WRInaute occasionnel
    Inscrit:
    5 Novembre 2018
    Messages:
    461
    J'aime reçus:
    49
    effectivement, j'ai connu exactement ce cas sur un site. Le site avait été repris from scratch d'une vieille version avec le schéma habituel de l'ancienne société qui a freiné des quatre pieds pour transmettre le minimum vital. Tout a été bien fait et remis à zéro (on parle de gros sites avec plein de pages), redirections... et le nouveau a claironné (surtout en conversions) et s'est stabilisé.
    Le dernier update probable, le site est passé du ttop3 à la page 7
    L'occasion de retourner dans le search console (très peu utilisé dans ce cas).

    Effectivement, dans la zone sitemap, un vieux truc est sorti de nul part de l'ancien site et pointait sur un fichier inexistant. Ca a été corrigé, comme d'habitude les classement sont revenus tous seuls mais quand a dire que c'était ce vieux sitemap sorti de nulle part ?
     
  4. Fred
    Fred WRInaute discret
    Inscrit:
    4 Avril 2019
    Messages:
    96
    J'aime reçus:
    9
    Je viens de découvrir un problème un peu similaire sur mon site :
    • Présence d'un vieux sitemap dans la version http du site sur la SC.
    • Problème de redirection en https mal effectuée au moment de la migration de serveur (de mutualisé à VPS).
    • Présence d'un sitemap portant le même nom dans la version https du site sur la SC.
    • Suite au passage de All in one Seo à Yoast SEO le sitemap.xml était redirigé vers sitemap_index.xml. Lequel Sitemal_xml redirige vers des sous sitemap (donc double redirection).
    C'est en examinant les logs googlebot de mon serveur que je m'en suis aperçu. Il y avait plusieurs demandes consécutives de /sitemap.xml avec des redirections 301 (mes logs ne précisent pas si la demande se fait en http ou https). Cela m'a mis la puce à l'oreille. Je ne comprenais par pourquoi googlebot demandait 3 ou 4 fois consécutive le sitemap.xml et était redirigé en 301.

    J'ai donc examiné à la loupe tous les logs.

    Je me suis aperçu que google avait recommencé à crawler des url en http alors qu'il n'en crawlait quasiment plus avant la migration de serveur.

    Je suis me aperçu de plein de problèmes qui ne se voyaient pas si l'on examine pas les logs serveurs. Je comprends aujourd'hui à quel point c'est indispensable de les examiner pour comprendre certains problèmes.

    Bon je n'ai pas la réponse pour le moment pour savoir si ce vieux sitemap http est l'origine de ma grosse chute, la correction ne datant que de quelques jours. J'en saurai plus dans quelques semaines.
     
Chargement...
Similar Threads - Mauvais sitemap statique Forum Date
Prise en compte mauvais sitemaps, possible ? Crawl et indexation Google, sitemaps 15 Octobre 2014
CTR très bas / "mauvaise page indexée" Problèmes de référencement spécifiques à vos sites Lundi à 19:16
Quel hébergement ? ( Mauvaise expérience O2switch) Administration d'un site Web 4 Décembre 2019
Après un piratage et un nettoyage, que faire des mauvais backlinks persistants? Problèmes de référencement spécifiques à vos sites 26 Novembre 2019
Blog wordpress piraté ? Des dizaines de nouveaux mauvais Backlinks Netlinking, backlinks, liens et redirections 10 Novembre 2019
33% de contenu dupliqué. Bon ou mauvais score ? Débuter en référencement 9 Septembre 2019
WordPress Mauvais référencement des catégories d'articles Problèmes de référencement spécifiques à vos sites 16 Août 2019
Google indique une mauvaise date dans le snippet Référencement Google 5 Août 2019
Mauvais score Backlinks Débuter en référencement 16 Juillet 2019
Mauvais affichage menu en https (https imposé par google) Développement d'un site Web ou d'une appli mobile 15 Juin 2019
  1. Ce site utilise des cookies. En continuant à utiliser ce site, vous acceptez l'utilisation des cookies.
    Rejeter la notice