Pb avec les accents dans la balise meta Titre

conseils

WRInaute discret
Bonjour à tous,

Depuis peu lorsque j'écris un mot avec un accent dans la balise méta Titre, ce mot s'écrit bizarrement du type "mutualité" pour "mutualité" ce qui se voit dans les résultats de recherche.

Quelqu'un aurait-il une solution ? Y a t-il une raison à cela ?

Merci d'avance pour vos réponses,
 

spout

WRInaute accro
C'est que tu réencodes une 2ième fois en entités HTML:
Code:
<title>mutualit&amp;eacute;</title>

Si ton encodage est bien renseigné, tu peux écrire directement:
Code:
<title>mutualité</title>
 

Rv323

WRInaute discret
Bonjour,

Utilise utf-8 si tu n'encodes pas tes accents et iso-8859-2 dans le cas contraire.

Code:
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
 

gamewinner

WRInaute discret
Il faut utiliser le bon charset. Pour un site en français utilise :

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
 

Rv323

WRInaute discret
UTF-8 fonctionne également très bien pour les sites FR même depuis un OS anglais (Windows ou Mac) sans aucune installation supplémentaire.

Je rencontre moins de problèmes qu'avec entre autre iso-8859-1 notamment quand ces balises sont reprises dans les serp ou autre. Je bosse sur 14 langues différentes y compris l'Arabe (rtl) pour divers clients.
 

JanoLapin

WRInaute accro
gamewinner a dit:
Il faut utiliser le bon charset. Pour un site en français utilise :

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
Pourquoi ? On peut aussi bien utiliser de l'utf-8.

Ce qui est important, et c'est la chose qui compte le plus, c'est bien l'adéquation entre le système d'encodage annoncé et celui réellement pratiqué par son éditeur du fichier
 

Discussions similaires

Haut