[résolu] problème de variables chez OVH

Discussion dans 'Développement d'un site Web ou d'une appli mobile' créé par zeb, 21 Février 2009.

Tags:
  1. zeb
    zeb WRInaute accro
    Inscrit:
    5 Décembre 2004
    Messages:
    12 024
    J'aime reçus:
    1
    Bonjour,

    J'ai un problème chez OVH.
    Les variables sous la forme $var1 écrasent les $_SESSION['var1']

    J'avais vu un truc du genre il y a longtemps mais je ne me souviens plus de l'histoire.

    Avez vous une idée qui m'éviterais de renommer toutes mes variables ? (je suis sous php5)
     
  2. u94082
    u94082 WRInaute occasionnel
    Inscrit:
    23 Août 2008
    Messages:
    257
    J'aime reçus:
    0
    Re: problème de variables chez OVH

    Salut,

    C'est pas une des options à la c*n de php5 ? Genre register globals ou un truc du genre... T'as accès à ta configuration php ?
     
  3. zeb
    zeb WRInaute accro
    Inscrit:
    5 Décembre 2004
    Messages:
    12 024
    J'aime reçus:
    1
    Re: problème de variables chez OVH

    c'est un 720 j'en ai pas la moindre idée je travail pas avec OVH d'habitude.
     
  4. ortolojf
    ortolojf WRInaute accro
    Inscrit:
    14 Août 2002
    Messages:
    3 572
    J'aime reçus:
    32
    Re: problème de variables chez OVH

    Bizarre, bizarre...

    Sous PHP 5, la directive "register globals" est à "Off" par défaut.

    Donc ton problème ne devrait pas se produire.

    Mais si OVH met cette directive à "On", làààààà.... Faut pas qu'il n'y ait d'autres variables nommées pareil. ;)

    Bien à vous.

    Amicalement.

    Jean-François Ortolo
     
  5. u94082
    u94082 WRInaute occasionnel
    Inscrit:
    23 Août 2008
    Messages:
    257
    J'aime reçus:
    0
    Re: problème de variables chez OVH

    C'est donc bien ça... Punaise, vivement PHP6 !

    Donc tu n'as plus qu'à les appeler et à leur demander de passer cette directive sur "off"...
     
  6. zeb
    zeb WRInaute accro
    Inscrit:
    5 Décembre 2004
    Messages:
    12 024
    J'aime reçus:
    1
    Re: problème de variables chez OVH

    En fait la valeur par défaut est douteuse mais il est possible d'interagir facilement.

     
  7. zeb
    zeb WRInaute accro
    Inscrit:
    5 Décembre 2004
    Messages:
    12 024
    J'aime reçus:
    1
    Re: problème de variables chez OVH

    Il y aura toujours un problème a droite ou a gauche avec une nouvelle version.
    Je ne suis pas certain que ce soit forcement mieux.
    Quoi qu'il en soit ce n'est pas un bug mais une question de config donc ... tout va bien.
     
  8. ortolojf
    ortolojf WRInaute accro
    Inscrit:
    14 Août 2002
    Messages:
    3 572
    J'aime reçus:
    32
    Beuh...

    PHP 6...

    J'ai entendu dire, qu'au niveau des traitements de chaînes de caractères, PHP 6 prendrait en compte les caractères utf-8 en natif... Or moi, je suis en iso-8859-1. ;(

    Si je dois adapter tout mon site pour garder la compatibilité iso, dur, dur...

    Et... Le moment venu, Sivit mon hébergeur, ne nous donnera probablement pas le choix, de garder PHP 5, beuh heu heu...

    Bien à vous.

    Amicalement.

    Jean-François Ortolo
     
Chargement...
Similar Threads - [résolu] problème variables Forum Date
Problème images en https (forum phpbb) [résolu] Développement d'un site Web ou d'une appli mobile 18 Novembre 2017
[RESOLU] probleme d'indexation des pages en httpS Crawl et indexation Google, sitemaps 20 Mars 2012
[Résolu] Problème d'importation de base MySQL en UTF8 chez 1&1 Administration d'un site Web 3 Juillet 2011
[Résolu] Problème pour gérer 2 campagnes AdWords 17 Novembre 2010
[RESOLU] Probleme d'erreur 302 non voulue Développement d'un site Web ou d'une appli mobile 30 Mai 2010
[Résolu] Problème de remonté de stats de campagne mails via GA Google Analytics 13 Mai 2010
[RESOLU]probleme lors de l'update des informations Développement d'un site Web ou d'une appli mobile 7 Avril 2010
[RESOLU] probleme de tri descendant de tableau ... Développement d'un site Web ou d'une appli mobile 4 Avril 2010
[résolu] Problème sur certains navigateurs ? Développement d'un site Web ou d'une appli mobile 16 Octobre 2009
probleme area="poly" et placement de div [RESOLU] Développement d'un site Web ou d'une appli mobile 8 Octobre 2009
[RESOLU] Problème avec PHPMAILER (apparition des headers dans le message) Développement d'un site Web ou d'une appli mobile 31 Juillet 2009
Problème URL Rewriting complexe avec les dossiers rééls et les autres chemins [Résolu] URL Rewriting et .htaccess 16 Juin 2009
[Résolu] Problème de onbeforeunload / frame Développement d'un site Web ou d'une appli mobile 12 Juin 2009
[Resolu]Probleme soumission boutique 1and1 Problèmes de référencement spécifiques à vos sites 25 Mai 2009
[résolu] problème php chez OVH Développement d'un site Web ou d'une appli mobile 9 Février 2009
[RESOLU] Problème de redirection permanente URL Rewriting et .htaccess 18 Janvier 2009
Probleme de formulaire [Résolu] Développement d'un site Web ou d'une appli mobile 18 Janvier 2009
[résolu] Problème avec preg_replace (le point) Développement d'un site Web ou d'une appli mobile 6 Janvier 2009
[résolu] Problème de téléchargent de fichiers .ttf, .rar ... Administration d'un site Web 26 Novembre 2008
[Résolu] Problème de cache ou d'historique Administration d'un site Web 8 Octobre 2008