Indexation très incomplète

linkcit

WRInaute discret
Salut à tous

j'ai un gros problème avec 2 sites sous Joomla qui sont sur le même serveur (Kimsufi chez OVH). Les deux sites sont en lignes depuis quelques mois et sont très mal indexés il n'y a que quelque URL des sitemaps qui sont indexés.

je me demande si le problème ne vient pas du serveur car sur un autre site sous Joomla également je n'ai pas de souci et il est sur un autre serveur.

Mes versions de Joomla sont bien à jour, j'ai bien mis en place des optimisations et des réécritures d'url etc..

pour etre claire (en me basant sur les données de Google webmaster Tools) :
- site n°1 sur serveur mutu : sitemap de 23 URLs dont 22 URLs indexées (pas de souci donc)
- site n°2 sur dédié OVH : sitemap de 10 URLs dont 4 URLs indexées (pas bon)
- site n°3 sur dédié OVH : sitemap de 57 URLs dont 6 URLs indexées seulement (pas bon du tout)

Je n'ai trouvé aucune info que ce probleme qui dure depuis un moment j'espere que vous pourrez m'aider à trouver une solution.
avez vous une idée du pb ? je peux vous fournir les liens en mp si besoin.

Merci beaucoup
 

Madrileño

Membre Honoré
Chaque site a un référencement différent, il est possible que certains sites ne soient pas optimisés, manques de liens, il faut aussi vérifier le duplicate content... Vous pouvez présenter les sites pour avoir des conseils des membres.
 

Madrileño

Membre Honoré
linkcit a dit:
- site n°1 sur serveur mutu : sitemap de 23 URLs dont 22 URLs indexées (pas de souci donc)
- site n°2 sur dédié OVH : sitemap de 10 URLs dont 4 URLs indexées (pas bon)
- site n°3 sur dédié OVH : sitemap de 57 URLs dont 6 URLs indexées seulement (pas bon du tout)
Le site présente approximativement 30 pages indexées.
Les outils de GWT ne sont peut-être pas à jour.
Pouvez-vous préciser si c'est le site 1, 2 ou 3 qui est celui présenté.
 

mahdivitchee

WRInaute discret
Bonjour

pour ton site tu as aussi problème des anciens pages

problème de connexion à la base de donnée , si tu es supprimer ces pages fait un redirection 301

pour déterminer les page indexé : requete site:
 

Madrileño

Membre Honoré
Il faudrait vérifier si le fichier sitemaps est à jour et comme le précise Mahdivitchee de vérifier les redirections.
Il faudrait vérifier aussi si les autres sites n'ont pas les mêmes corrections qui peuvent expliquer le manque de référencement.
 

linkcit

WRInaute discret
je pense avoir trouvé un gros souci de duplicate content ... je vous tiens au courant mais priori c'est ça le probleme !

@mahdivitchee : merci pour ta contribution :) ces urls sont des liens internes vers des lightbox sur certaines image...
Peux tu , STP, masquer l'URL du site dans ton poste ?? merci pour ta compréhension.
 

linkcit

WRInaute discret
Madrileño merci pour l'info !

par contre mon problème n'est pas réglé ... j'ai effectivement trouvé un probleme de duplicate content mais sur une seule page du site !!

je vois vraiement pas d'ou peut venir le probleme !!!
 

Madrileño

Membre Honoré
linkcit a dit:
je vois vraiement pas d'ou peut venir le probleme !!!
Madrileño a dit:
linkcit a dit:
- site n°1 sur serveur mutu : sitemap de 23 URLs dont 22 URLs indexées (pas de souci donc)
- site n°2 sur dédié OVH : sitemap de 10 URLs dont 4 URLs indexées (pas bon)
- site n°3 sur dédié OVH : sitemap de 57 URLs dont 6 URLs indexées seulement (pas bon du tout)
Le site présente approximativement 30 pages indexées.
Pouvez-vous préciser si c'est le site 1, 2 ou 3 qui est celui présenté.
Sachant que le site à 30 pages indexées, il faudrait guider un peu les membres pour pouvoir vous aider.
 

linkcit

WRInaute discret
Desolé !
je parle du 3ème site.
je me rend compt petit à petit que j'ai pas mal d'erreurs 404 parmis ces 30 liens. Est ce que cela peut expliquer le fait que Google bloc l'indexation apres trop d'erreurs ??
 

Madrileño

Membre Honoré
Le robot de Google essaye de crawler votre site, s'il y a des erreurs il va vérifier plusieurs fois la page pour savoir si c'est temporaire ou pas et donc l'indexation des pages correctes peut aussi être moins rapide. Vérifier si vous n'avez pas d'erreurs avec les liens des pages et que les pages qui sont crawlés sont correctes. Vérifier votre sitemaps et proposer le fichier à nouveau.
 

linkcit

WRInaute discret
Bonjour

j'ai bien vérifier tout ça. j'ai fais des redirections sur les pages d'erreurs et supprimer les liens morts de google.
l'indexation du sitemap n'évolue pas du tout depuis 4 jours.

J'ai mis des liens interieurs sur la page d'accueil pour améliorer l'indexation en profondeur. Est ce que c'est une bonne solution d'après vous ?
Est ce que je dois peut être booster les backlink ?

J'ai vérifié également sur un site que j'ai depuis plus d'un an en ligne et sur 261 url envoyées du sitemap j'en ai seulement 148 indexées...

Aussi je viens de constater que yahoo m'indexe beaucoup mieux que google et bing (bing me demande une indexation manuelle de chaque page)
 

Madrileño

Membre Honoré
Il faut le temps que les robots et les serveurs réalisent le travail.
Vous avez aussi éditer le site, ce qui limite les utilisateurs du forum pour les aides.
 

Discussions similaires

Haut