Probleme serveur CPU 100% Help

Discussion dans 'Administration d'un site Web' créé par extremenet, 16 Janvier 2009.

  1. extremenet
    extremenet WRInaute discret
    Inscrit:
    2 Octobre 2006
    Messages:
    161
    J'aime reçus:
    0
    Bonjour,

    je viens d'avoir un nouveau serveur un rps de chez ovh en release2.
    Depuis aujourd hui chez un souci avec, il bloque, pas moyer d'acceder au site, ni en ssh et ni avec webmin.

    Quand cela arrive voici ce que j'ai dans mon manager :

    Utilisation du Serveur Charge CPU : 100 %
    Charge RAM : 87 %
    Charge SWAP : 82 %
    Utilisation disque dur Utilisation(s) pour [ / ] : 35 %
    Utilisation(s) pour [ /home ] : 11 %

    Processus du serveur
    Serveur démarré depuis : 3 heure(s) 36 minute(s) 48 seconde(s)

    Charge moyenne ( loadavg1 ) : 61.95
    Charge moyenne ( loadavg2 ) : 84.16
    Charge moyenne ( loadavg3 ) : 171.82
    Processus actif(s) ( loadactive ) : 0
    Processus démarré(s) ( loadup ) : 364

    La premier fois qu il m a fait ca ce matin, j ai du le rebooter 4 fois pour tou refonctionne. et la aprés 3 heures de fonctionnement, c'est reparti.

    Quelqu un pourrez me dire ce que je peu regarder une fois qu il que je vais le redemarez avant qu il rebloque pour trouver une solution.

    Sachant qu il tournait depuis une semaine sans probléme et que je n'est pas fais de modification de logiciel.

    Merci par avance de votre aide.
     
  2. YoyoS
    YoyoS WRInaute accro
    Inscrit:
    14 Septembre 2006
    Messages:
    3 226
    J'aime reçus:
    0
    Oue c'est énorme on dirait ^^ Réinstalle le lol
     
  3. Mitirapa
    Mitirapa WRInaute passionné
    Inscrit:
    10 Juillet 2002
    Messages:
    1 160
    J'aime reçus:
    0
    un top trié par cpu usage et par mémoire ca donne quoi ?
    et tes logs ya rien de bizarre ?
     
  4. extremenet
    extremenet WRInaute discret
    Inscrit:
    2 Octobre 2006
    Messages:
    161
    J'aime reçus:
    0
    Voici le top ce qu'il me donne :

    top - 20:09:04 up 4:46, 1 user, load average: 78.88, 57.05, 55.39
    Tasks: 302 total, 2 running, 300 sleeping, 0 stopped, 0 zombie
    Cpu(s): 1.8% us, 1.1% sy, 0.0% ni, 0.0% id, 96.9% wa, 0.0% hi, 0.2% si
    Mem: 474684k total, 469976k used, 4708k free, 3512k buffers
    Swap: 503800k total, 302636k used, 201164k free, 25108k cached

    PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
    23586 root 20 0 2248 1036 736 R 0.1 0.2 0:03.50 top
    23603 petition 20 0 29364 14m 2136 D 0.1 3.0 0:00.22 php
    23606 petition 20 0 29816 8972 2144 D 0.1 1.9 0:00.20 php
    23659 petition 20 0 28936 8264 2148 D 0.1 1.7 0:00.20 php
    23665 petition 20 0 32960 13m 2136 D 0.1 2.9 0:00.24 php
    23789 mysql 20 0 75396 18m 2368 D 0.1 4.1 0:00.84 mysqld
    23835 mysql 20 0 75396 18m 2368 S 0.1 4.1 0:00.82 mysqld
    23862 mysql 20 0 75396 18m 2368 D 0.1 4.1 0:00.78 mysqld
    23966 mysql 20 0 75396 18m 2368 S 0.1 4.1 0:00.84 mysqld
    24154 petition 20 0 28088 11m 2160 D 0.1 2.5 0:00.18 php
    24317 petition 20 0 29960 13m 2160 D 0.1 2.9 0:00.20 php
    24319 mysql 20 0 75396 18m 2368 S 0.1 4.1 0:00.82 mysqld
    24612 qscand 20 0 7336 2728 1372 D 0.1 0.6 0:00.20 qmail-scanner-q
    24675 mysql 20 0 75396 18m 2368 D 0.1 4.1 0:00.22 mysqld
    24702 mysql 20 0 75396 18m 2368 D 0.1 4.1 0:00.20 mysqld
    1 root 20 0 1480 76 56 D 0.0 0.0 0:12.46 init
    2 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kthreadd
    3 root RT -5 0 0 0 S 0.0 0.0 0:00.00 migration/0
    4 root 15 -5 0 0 0 S 0.0 0.0 0:00.36 ksoftirqd/0
    5 root 15 -5 0 0 0 S 0.0 0.0 0:00.72 events/0
    6 root 15 -5 0 0 0 S 0.0 0.0 0:00.42 khelper
    85 root 15 -5 0 0 0 S 0.0 0.0 0:00.32 kblockd/0
    87 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kacpid
    88 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kacpi_notify
    153 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 ata/0
    154 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 ata_aux
    155 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 ksuspend_usbd
    160 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 khubd
    163 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kseriod
    200 root 20 0 0 0 0 D 0.0 0.0 0:00.84 pdflush
    201 root 15 -5 0 0 0 D 0.0 0.0 2:27.12 kswapd0
    202 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 aio/0
    207 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 xfslogd/0
    208 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 xfsdatad/0
    209 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 xfs_mru_cache
    888 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 scsi_eh_0
    890 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 scsi_eh_1
    901 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 mtdblockd
    928 root 15 -5 0 0 0 S 0.0 0.0 0:00.00 kpsmoused


    Mais bizarre au bout d'un moment j ai la eam et le swap qui descende de même pour le processus actif, mais la c'est reparti ca remonte. Le cpu ne bouge pas il reste à 100%. dans quelle log il faut que je regarde ?

    Merci
     
  5. extremenet
    extremenet WRInaute discret
    Inscrit:
    2 Octobre 2006
    Messages:
    161
    J'aime reçus:
    0
    Utilisation du Serveur Charge CPU : 100 %
    Charge RAM : 53 %
    Charge SWAP : 30 %
    Utilisation disque dur Utilisation(s) pour [ / ] : 35 %
    Utilisation(s) pour [ /home ] : 8 %

    Processus du serveur
    Serveur démarré depuis : 4 heure(s) 43 minute(s) 24 seconde(s)

    Charge moyenne ( loadavg1 ) : 50.71
    Charge moyenne ( loadavg2 ) : 41.92
    Charge moyenne ( loadavg3 ) : 51.13
    Processus actif(s) ( loadactive ) : 43
    Processus démarré(s) ( loadup ) : 282


    ca c'est quand il commence a remonter les processus ete descendu à 123
     
  6. Bool
    Bool WRInaute passionné
    Inscrit:
    26 Février 2004
    Messages:
    1 543
    J'aime reçus:
    0
    Normal que ça pédale sec avec ce genre de choses.
     
  7. extremenet
    extremenet WRInaute discret
    Inscrit:
    2 Octobre 2006
    Messages:
    161
    J'aime reçus:
    0
    je viens de le lancer en rescue pour sauvegarde. vu que j ai pas eu reponse. ensuite je relance une installation complete.
     
  8. extremenet
    extremenet WRInaute discret
    Inscrit:
    2 Octobre 2006
    Messages:
    161
    J'aime reçus:
    0
    Bon la c'est pire il est indisponible depuis 2 heures, ping impossible, reboot : donne rien. :-(
     
Chargement...
Similar Threads - Probleme serveur CPU Forum Date
Problème de htaccess et de CPU serveur URL Rewriting et .htaccess 11 Février 2010
Problème serveur connexion simultanée Administration d'un site Web 19 Janvier 2022
Problème de temps de réponse serveur entre 2 site hébergé sur le même serveur Administration d'un site Web 22 Mars 2017
Problème avec le nouveau serveur Crawl et indexation Google, sitemaps 27 Août 2015
Problème de connectivité au serveur Problèmes de référencement spécifiques à vos sites 2 Juin 2014
Problème serveur mail suite changement DNS Administration d'un site Web 21 Novembre 2013
Probléme de serveur dédié, 400€ de réparation ? Administration d'un site Web 11 Décembre 2012
Probléme de serveur bloqué Problèmes de référencement spécifiques à vos sites 15 Novembre 2012
Probleme sous domaine vers autre site du serveur Administration d'un site Web 22 Octobre 2012
Problème d'URL, le serveur ne répond pas Débuter en référencement 30 Mars 2012
Déclassement et problème serveur Référencement Google 18 Octobre 2011
Problème mail Yahoo (serveur POP) Le café de WebRankInfo 17 Août 2011
Problème sur serveur : Disque dur à 100% & Saturation sans raisons Administration d'un site Web 16 Juin 2011
Problème emailing de mon serveur dédié Administration d'un site Web 20 Février 2011
RESOLU :: probleme d'affichage arabe : sur un serveur toute est bon l'autre non Développement d'un site Web ou d'une appli mobile 24 Août 2010
probleme creation fichier php sur serveur Développement d'un site Web ou d'une appli mobile 15 Juillet 2010
Problème d'optimisation de la base de donnée? ou problème du serveur Développement d'un site Web ou d'une appli mobile 11 Avril 2010
Problème de mémoire sur un serveur Administration d'un site Web 19 Février 2010
Probleme de redirection d'un serveur a un autre ! URL Rewriting et .htaccess 22 Janvier 2010
Probleme d'envoi de mail en html avec serveur smtp Développement d'un site Web ou d'une appli mobile 7 Décembre 2009